Error first setup letsencrypt using Digital Ocean

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):
Server version: Apache/2.4.18 (Ubuntu)

The operating system my web server runs on is (include version):
Ubuntu 16.04

My hosting provider, if applicable, is:
Digital Ocean

I installed Certbot with (certbot-auto, OS package manager, pip, etc):

I ran this command and it produced this output:
sudo certbot --authenticator standalone --installer apache --pre-hook “systemctl stop apache2” --post-hook “systemctl start apache2”

Logs are stored in /var/log/letsencrypt by default. Feel free to redact domains, e-mail and IP addresses as you see fit.
File “/usr/lib/python2.7/dist-packages/certbot/”, line 698, in run
certname, lineage)
File “/usr/lib/python2.7/dist-packages/certbot/”, line 85, in _get_and_save_cert
lineage = le_client.obtain_and_enroll_certificate(domains, certname)
File “/usr/lib/python2.7/dist-packages/certbot/”, line 375, in obtain_and_enroll_certificate
File “/usr/lib/python2.7/dist-packages/certbot/”, line 1019, in new_lineage
OSError: [Errno 20] Not a directory: ‘/etc/letsencrypt/live/’
2018-02-05 15:00:32,837:ERROR:certbot.log:An unexpected error occurred:

Hi @KhairulAzmi21,

Did you previously change the contents of /etc/letsencrypt in some way, like by moving or renaming things there?

i dont think so . i just created droplet on DO . and follow the tutorial as above

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.