Apache Certificate not installed


#1

Hello,

I am able to generate SSL certificate by using "certbot-auto certonly --apache -d ‘www.mytestdomain.com " command, and after that, it wont configured in my httpd.conf file which i have virtual host configuration on the file.

Can you help on this.

Thanks in advance
Rajkumar S


#2

That’s correct; using the certonly command told it to not install the cert, but only to generate it.

Edit your apache config file(s) to point to the cert you just created.


#3

Thank you @danb35,

After removing the “certonly” command , the certbot auto command installed my certificates automatically to httpd conf.

I have one more doubt on this. Now Lets encrypt asked me that Redirect to HTTPS. is there any possible to make this permanent as i am working on the full automation process of creating and renewing process.

Thanks in advance
Rajkumar S


#4

You only need to set this redirect once. (Renew will not present this dialog, just simply renew)

However, if you want to enable https by default (Enable without visitors viewing your website), go for hsts & preload.

Thank you


#5

If you do want to set the redirect without being prompted, the command line option to Certbot is --redirect. As @stevenzhu explained, it would only have an effect when you first obtain the certificate, not for subsequent renewals, but maybe you’re looking to automate this part too.


#6

@schoen @stevenzhu

Thank you of both.

Sure i will check with the --redirect command automate this part. For renewal i will work for another script.