Why certbot doesnot create automatically an ssl version of the apache conf for my site?

My probleme is similar to this thread : My website is not working on https by using letsencrypt certificates

On march 2017 I created on Debian 7 an SSL for one site, and the SSL virtualhost configuration file for the SSL version was automatically created, but today on June, this Vhost configuration is note created anymore hence the SSL_ERROR_RX_RECORD_TOO_LONG message, i notice the ssl vhost file is not present.
How to create it automatically?

Hi @refschool,

Do you mean that the HTTPS virtual host for your previous site was created and then later removed, or that you obtained a new, separate certificate for a different virtual host and didn’t get an appropriate virtual host configuration file for the new certificate?

In the second case my guess would be that you used certonly, which does not attempt to install the certificate or configure the web server.

HI thanks you got the point, I created it with certonly parameter !

OK! The meaning of certonly is “only obtain a certificate, do not attempt to install it”.

If you want Certbot to try to configure your Apache, you can use certbot --apache which will also attempt to install the certificate (by creating an HTTPS virtualhost which references that certificate). Otherwise, you will have to do so yourself.

I believe there’s a lot of documentation out there about how to create an HTTPS virtualhost in Apache, so you could use either approach. There is also an option certbot --reinstall --apache (where you’ll also need to respecify all of the domains with -d or else specify the certificate name with --cert-name so that Certbot knows which certificate you would like it to install). This may be able to use your existing certificate and separately perform the installation step.

thanks for the extra info, i managed to get everything running smoothly ! at the moment i prefer doing thing manually in order to understand more.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.