Add www on renewal


I just realise that wend i first run letsencrypt-auto i did forgot to include the www. subdomain now that i realise that and it’s time to renew i wonder whats the best option to also include the www.

./letsencrypt-auto certonly -d -d

gives me An unexpected error occurred

thanks in advance


You probably want to add the --expand flag in order to tell the client to replace the existing certificate instead of creating a new directory to store it in.

That being said, that’s not why this error is occuring. Could you provide more details about the error? You should see a longer message along with “An unexpected error occurred”. There might also be more details in /var/log/letsencrypt.


Ty for tour time. My log shows:

File “/home/bitnami/.local/share/letsencrypt/local/lib/python2.7/site-packages/”, line 1746, in _widget_with_string_output
code, output = self._perform(args, **kwargs)
File “/home/bitnami/.local/share/letsencrypt/local/lib/python2.7/site-packages/”, line 1541, in _perform
File “/home/bitnami/.local/share/letsencrypt/local/lib/python2.7/site-packages/”, line 1502, in _handle_program_exit
File “/home/bitnami/.local/share/letsencrypt/local/lib/python2.7/site-packages/”, line 1454, in _wait_for_program_termination


Any chance your terminal window is particularly small? I think the client might have issues drawing the dialogs in that case. Making the terminal window bigger should avoid that.

You could also add the --text flag to use a text-only interface, which should avoid this issue.


Ty very much. I just needed to enlarge the window.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.