Action required: Let's Encrypt certificate renewals


#1

Hallo,
this is my first post here … and please excuse my English.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: owncloud.franziska-hoell-schule.de

I ran this command: After getting the E-Mail I first installed certbot (Version 0.23.0-1) as replacement for letsencrypt.

Then I ran this command:

root@owncloud:~# certbot renew --dry-run

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log


Processing /etc/letsencrypt/renewal/owncloud.franziska-hoell-schule.de.conf

Cert not due for renewal, but simulating renewal for dry run
Plugins selected: Authenticator apache, Installer apache
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for owncloud.franziska-hoell-schule.de
Waiting for verification…
Cleaning up challenges
Attempting to renew cert (owncloud.franziska-hoell-schule.de) from /etc/letsencr ypt/renewal/owncloud.franziska-hoell-schule.de.conf produced an unexpected error : Failed authorization procedure. owncloud.franziska-hoell-schule.de (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the cli ent to verify the domain :: Fetching http://owncloud.franziska-hoell-schule.de/. well-known/acme-challenge/oIq278Gg4pEdO7zmQ_u6Q7aJxFRRbwqTLbNRUiyma2Q: Timeout d uring connect (likely firewall problem). Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/owncloud.franziska-hoell-schule.de/fullchain.pem (failur e)


** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates below have not been saved.)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/owncloud.franziska-hoell-schule.de/fullchain.pem (failur e)
** DRY RUN: simulating ‘certbot renew’ close to cert expiry
** (The test certificates above have not been saved.)

1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: owncloud.franziska-hoell-schule.de
    Type: connection
    Detail: Fetching
    http://owncloud.franziska-hoell-schule.de/.well-known/acme-challenge/oIq278Gg 4pEdO7zmQ_u6Q7aJxFRRbwqTLbNRUiyma2Q:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): apache2 2.4.29

The operating system my web server runs on is (include version):ubuntu 18.04 LTS

My hosting provider, if applicable, is: belwue

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no, only terminal


#2

Hi @wilfried1

I see, you have already tested your domain - https://check-your-website.server-daten.de/?q=owncloud.franziska-hoell-schule.de

Your port 80 is closed or no http is configured.

Domainname Http-Status redirect Sec. G
http://owncloud.franziska-hoell-schule.de/
141.10.57.220 -14 10.026 T
Timeout - The operation has timed out
https://owncloud.franziska-hoell-schule.de/
141.10.57.220 200 6.540 B
http://owncloud.franziska-hoell-schule.de/.well-known/acme-challenge/check-your-website-dot-server-daten-dot-de
141.10.57.220 -14 10.027 T
Timeout - The operation has timed out

Is there a http server running?

Is there a firewall which blocks port 80?


#3

Hallo Juergen,

the ubuntu-server is only in use for a nextcloud.

When i run the command netstat -tuplen, port 80 is only shown for tcp6.
I tried to open port 80 with this command:
iptables -A INPUT -p tcp --dport 80 -j ACCEPT
but without any success.


#4

This isn’t a problem if port 80 is only visible via tcp6.

But there - https://check-your-website.server-daten.de/?q=owncloud.franziska-hoell-schule.de - I don’t see an ipv6 address.

So add the ipv6 in your nameserver settings.

Letsencrypt prefers ipv6.


#5

This output may be misleading.
If it showed [::]:80 (or :::80) then it may be bound to both IPv4 and IPv6.
You should test it locally with curl to see which are responding:
curl -4 127.0.0.1:80
curl -6 [::1]:80
(or you can use your specific IPv4 & IPv6 addresses)


#6

The ipv6 adress is only internal.
Port 80 ist closed per default, because the user of the nextcloud should only use port 443.


#7

Then you must open port 80 or you must switch to dns-01 - validation.


#8

I have asked my ISP to open port 80 and now everything works fine.
Thank you for your helpful hints.


closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.