Action "Graceful" Failed (Bitnami)


#1

My domain is: crestoneadvising.com

I ran this command: sudo certbot --apache

It produced this output:

My web server is (include version): AWS Lightsail Instance, 1 GB RAM, 1 vCPU, 30 GB SSD (Linux 4.4.0-1052-aws x86_64)

The operating system my web server runs on is (include version): apache Ubuntu 16.04.4

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): Yes, but I am using a Bitnami wordpress stack, so it has me sign in as bitnami as the user, but you can run most root user commands.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Wordpress?

I installed certbot on two sites just over 90 days ago. Per expected, the certificates expired. So I tried to go in and renew the certificates and it would say something to the extent of “This domain cannot be fully verified” and then it tries running a couple of other commands to resolve it and they all fail. So I decided to just try starting a new wordpress instance and trying to secure it with a different installation method. When I did, it gave me the readout above. Any tips would be amazing! Thank you

Also, I did take a look at the topic that was already on here (Action 'graceful' failed), but it is not what is happening with mine.


#2

Bitnami provides these instructions for using Let’s Encrypt with their stacks, which might be worth a try:

https://docs.bitnami.com/general/how-to/generate-install-lets-encrypt-ssl/

If you follow that, though, be warned that the auto-renewal only runs once a month and doesn’t seem to automatically retry if it fails, so make sure to use a valid email address that you check regularly so that you’ll receive the reminder messages if your cert gets close to expiry.

(I’m not familiar enough with the lego client to suggest how to improve the tutorial, sorry).

It’s also worth mentioning that http://crestoneadvising.com currently doesn’t seem to be responding, at least for me. Are you sure you’ve got your security groups etc set up correctly? Your site needs to be accessible to the internet on port 80 for the validation to work.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.