404 page not found


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: frescohealth.com

I ran this command: I went through the process, step-by-step…have interacted with Steven several times. He asked me to start a new ticket. He had me remove “txt” at the end of the files in the CPanel. I did that as well but it still gives me the error “404 page not found”

It produced this output: 404 PAGE NOT FOUND

My web server is (include version): GoDaddy

The operating system my web server runs on is (include version): Mac

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): yes


#2

Can you be more clear?
Maybe post a picture of the problem…

I do see that the https site is using the wrong cert:


#3

Hi Rudy,

Thanks for your quick response.

I will have to go through everything again and send you the results, this will be about the 5th time so I’m not surrprised you’re seeing something old.

Peace and Blessings,

Rita Leatherman
Direct 865.712.7386

Energy Source Home Solutions
236 East Main St. #120
Sevierville, TN 37862
877.224.1447
Fax 866.869.0367

www.EnergySourceHome.com
www.FrescoHealth.com


#4

Here is latest results…


#5


#6

Hi @rdrg520

what’s your control panel? Doesn’t that has an integrated solution?

You have a lot of certificates. Two are active, other are expired.

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:true;include_subdomains:false;domain:frescohealth.com&lu=cert_search

How did you create these certificates?

Please create a file 1234 (no extension) in /.well-known/acme-challenge, so you should be able to load this file via

http://frescohealth.com/.well-known/acme-challenge/1234

One thing is curious. Checking your root, there are no cookies. But checking /.well-known/acme-challenge/1234, there is a http status 404 (which is ok) and there is a cookie

Set-Cookie: wp_woocommerce_session...

Perhaps there is a redirect to another server / instance.

Why is there a self signed certificate, if you have so much other Letsencrypt certificates?


#7

I’ve tried to help him using emails…

He uses GoDaddy hosting, which openly stated that they do not enable intergrate solutions and suggest to purchase GoDaddy certificates.


#8

Just by the way, the http root also have the same cookie…(checked by curl)

Thank you


#9

Interesting. I have completely different outputs:

http - the root - without cookie:

D:\temp>download http://frescohealth.com/ -h
Vary: Accept-Encoding,Cookie,User-Agent
Keep-Alive: timeout=5
Connection: Keep-Alive
Transfer-Encoding: chunked
Cache-Control: max-age=3, must-revalidate
Content-Type: text/html; charset=UTF-8
Date: Wed, 24 Oct 2018 10:06:09 GMT
Server: Apache
X-Powered-By: PHP/7.0.30

Status: 200 OK

597,60 milliseconds
0,60 seconds

And the not existing page:

D:\temp>download https://frescohealth.com/.well-known/acme-challenge/1234 -h
Only SslPolicyErrors.RemoteCertificateChainErrors found
SSL error: RemoteCertificateChainErrors
Error (1): Der Remoteserver hat einen Fehler zurückgegeben: (404) Nicht gefunden.
ProtocolError
Vary: Accept-Encoding,Cookie,User-Agent
Link: https://frescohealth.com/wp-json/; rel=“https://api.w.org/
Keep-Alive: timeout=5
Connection: Keep-Alive
Transfer-Encoding: chunked
Cache-Control: no-cache, must-revalidate, max-age=0
Content-Type: text/html; charset=UTF-8
Date: Wed, 24 Oct 2018 10:06:24 GMT
Expires: Wed, 11 Jan 1984 05:00:00 GMT
Set-Cookie: wp_woocommerce_session_6fa9a951667a2398b9850b07d6d879af=c13736e2aed8e86161f79560b7003ff7%7C%7C1540548385%7C%7C1540544785%7C%7C629daa62f98359e23bac1b527962cd54; expires=Fri, 26-Oct-2018 10:06:25 GMT; Max-Age=172800; path=/
Server: Apache
X-Powered-By: PHP/7.0.30

Status: 404 NotFound
404

2444,07 milliseconds
2,44 seconds

Different cache header, different cookies. And 0,6 vs 2,44 seconds. Looks like a redirect to another instance.

Perhaps this is part of the problem:

Vary: Accept-Encoding,Cookie,User-Agent

PS: Same with http and /.well-known/…


#10

Juergen / Steven,

I’m confused at this point, is there something else I should do? I believe Steven answered your questions, correct?

Thanks for your assistance,

Rita


#11

There - https://www.frescohealth.com/ - is a self signed certificate. There

https://transparencyreport.google.com/https/certificates?cert_search_auth=&cert_search_cert=&cert_search=include_expired:false;include_subdomains:false;domain:www.frescohealth.com&lu=cert_search

are only two certificates created 2018-08-08. So your creation of a new Letsencrypt certificate doesn’t work.

If Steven uses curl, he get’s a cookie. If I use my own tool, there is no cookie.

So it looks that your server produces different answers. This header

Vary: Accept-Encoding,Cookie,User-Agent

says that: Vary = different outputs, check Encoding, Cookies (sent back) and User-Agent.

Perhaps your 404 - status (not found) is a similar problem.


#12

I have spoke to GoDaddy, they said the file inside “acme-challenge” should be named something else. I told him I did not get that far through the process so I didn’t know what that name is…as I was stalled when I get "404 not found.


#13

Hello, can you check and see if anything has changed on my cert’s? I have cleaned up our CPanel; hopefully it has yielded good results.

Thanks for your assistance,
Rita


#14

https://www.ssllabs.com/ssltest/analyze.html?d=frescohealth.com
https://www.ssllabs.com/ssltest/analyze.html?d=www.frescohealth.com


#15

I see you have managed to get it fixed:


#16

Yes sir, I had GoDaddy issue one because I could not figure it out.

Peace and Blessings,