404 error with Apache - acme challenge


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.curaio.net

I ran this command:

When i use letsencrypt or browser to find file in my docroot ./well-knoww/acme-challenge the acme file to renew or create certificate it doesn’t work.

It produced this output:
I obtain 404. I tryed with test.html file either it produces same result if i put the file in .well-known directory it works I get 200.

My web server is (include version):
Apache 2.4.31
The operating system my web server runs on is (include version):
windows 2012
My hosting provider, if applicable, is:
ikoula
I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi @nono1974

windows-systems sometimes have problems with files without file-extension, Letsencrypt want’s such a file. I don’t know if the combination of Windows 2012 and Apache has also that problem.

So create a file /.well-known/acme-challenge/123456789

and test, if you can load it per

http://www.curaio.net/.well-known/acme-challenge/123456789


#3

PS: An older comment:

with the IIS-solution.


#4

Hi I have rollback all my wirtual host and ssl command in apache conf and now I a can reach the file. I will rebuild all my certificate. It seems to have a directive blocking my url path acme-challenge somewhere but didn’t find yet.


#5

I found the concern you must not load mod-md.so when you renew or manage the letsencrypt exe because it block access to the path acme-challenge for security reasons I guess.

By the way the right letsencrypt command for apache is : letsencrypt.exe --plugin manual …


#6

Now I see, your website works with https.

Thanks!

@schoen : Is it possible that Certbot checks this?


#7

Maybe we could ask @joohoi about this.


#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.