Acme-challenge gives me a 404


#1

I think I have an apache problem… you know where to look?

I get an 404 error when I try to access mydomain.com/.well-known/acme-challenge/test.txt, but if I try the same on the acme-challenge2 directory it works?

acme-challenge2 is a copy of acme-challenge. What wrong here? Is it apache?

drwxr-xr-x 2 root root 4.0K Feb 2 11:10 acme-challenge
drwxr-xr-x 2 root root 4.0K Feb 2 10:59 acme-challenge2

Apache Log:
139.162.227.80 - - [02/Feb/2017:11:32:35 +0000] “GET /.well-known/acme-challenge/text.txt HTTP/1.1” 404 962
139.162.227.80 - - [02/Feb/2017:11:32:40 +0000] “GET /.well-known/acme-challenge3/text.txt HTTP/1.1” 200 6

EDIT: It seems that what value I have in httpd-acme.conf prevents me from getting to the file


#2

Do you have a redirect in your apache config for .well-known/acme-challenge ?


#3

Can’t find any.

But I solved the problem - only I am not sure how. Played a bit around it the httpd-acme.conf and tried to run the chown -R root:root .well-known and suddently it works.


#4

Glad you got it fixed :slight_smile: even if not sure how.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.