You don't accept my autentication


#1

Good morning, I installed your certificate, but I receive an error and my website is now down.

My domain is:
www . fisioterapiarubiera . com

I ran this command:
I selected the ssl certificate

It produced this output:
Unfortunately, the check could not find a valid authentication method. You can generate authentication tokens via the “request authentication” option. Please keep in mind that DNS-based authentication may take a few hours before the entries are accessible.

My web server is (include version):
Apache - php 5

The operating system my web server runs on is (include version):
Apache

My hosting provider, if applicable, is:
Hetzner

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
KonsoleH


#2

Hi,

Your website www.fisioterapiarubiera.com seems to be up and running. The site is currently using a Comodo certificate which would not expire until 2020.

I am having trouble to find tutorials for KonsoleH (the in-house control panel for Hetzner), and it only come up with this https://wiki.hetzner.de/index.php/KonsoleH:SSL-Guide/en.

Did you follow a tutorial to request the certificate? If so, could you please provide me a link to that?

Also, what validation method did you use to request the certificate (and ultimately result in the error message?)

Thank you


#3

Hello,
Yes I put the dns back to my old server, I cannot let my website down for hours.
I put .well-known/acme-challenge and the 2 text files you asked me with the code inside.
I use KonsoleH, It is super easy, just to select the certificate and click on the redirect.


#4

Hi,

Do you mind to share a screenshot on your KonsoleH panel that showed the options you have when you tried to request the certificate?

There might be 3 options, DNS validation, HTTP (File) validation, and manual validation.

By the way, are you using a translation service to translate this topic? If so, do you mind to tell us what’s the language you generally speak? We might have volunteers that speak the same language you use, and this would reduce misunderstandings caused by machine translation.

Thank you


#5

Right


#6

Hi @massimodefilippo

we need the underlying options.

Perhaps first you have to define an authentication method. Then you can start to get a certificate.


#7

Ok, before I selected the let’s encrypt certificate, but now I cannot reselect it.

here the screen shots!

The files are in the place!

The DNS are changed.

BUT you don’t accept my certificate!

Why???


#8

When I visit https://www.fisioterapiarubiera.com/.well-known/acme-challenge/example I get redirected to the frontpage. Does this happen only for files that don’t exist or for any url under acme-challenge directory?

Put test.txt file in acme-challenge directory with the string test-token and check if you can see this string when you browse https://www.fisioterapiarubiera.com/.well-known/acme-challenge/test.txt.


#9

Hi,

I personally suggest you to contact your hosting provider for assistance on requesting the installation of certificate with the correct authenticator.

Thank you