Yet another "Challenge failed for domain..."

Hi all. I'm trying to install a certificate.. And yet, I encounter this challenge failed error.
Checked the DNS, it points at my domain. Access the domain, via browser and it works.. I'm at a loss.. Could anyone give me a hand ?
Thank you.

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
sudo certbot --apache

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):
ubuntu 16.04.7

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.9.0

1 Like

Hi Silviu, and welcome to the LE community forum!

There is an IP problem with your domain name servers:
See: | DNSViz

Also, from my view, both name servers return the same IP.
You can see a more complete DNS review at: DNS Spy report for
[this is not ideal; as this puts all your eggs in one basket]

1 Like

@rg305 While it's true what you're saying, it's not the issue at hand. OP is getting a 404 file not found, not a DNS error.

@za_sly What's the output of apachectl -S?


Hi @rg305

Thanks for taking the time to answer....
I have no idea who is.... :grimacing:
I will look into it.. as it seems weird.... is my external ip, and yes, I kow that both ns servers are identical.


Hi @Osiris
Thanks for replying.
apachectl -S actually gives me an error.... a syntax error, to be precise...

AH00526: Syntax error on line 44 of /etc/apache2/sites-enabled/000-apps.vhost:
SuexecUserGroup configured, but suEXEC is disabled: Invalid owner or file mode for /usr/lib/apache2/suexec
Action '-S' failed.

Now what.... ???


Try is as:
sudo apachectl -S

If that returns the same problem/error, then I guess you have to hunt that down - it would be an Apache configuration issue that may not be best resolved by this forum :frowning:

1 Like

My bad... forgot about sudo...
Here it is... :slight_smile:
AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
VirtualHost configuration:
*:8081 (/etc/apache2/sites-enabled/000-apps.vhost:9)
*:80 (/etc/apache2/sites-enabled/000-default.conf:1)
*:8080 (/etc/apache2/sites-enabled/000-ispconfig.vhost:9)
ServerRoot: "/etc/apache2"
Main DocumentRoot: "/var/www/html"
Main ErrorLog: "/var/log/apache2/error.log"
Mutex fcgid-proctbl: using_defaults
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex fcgid-pipe: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
PidFile: "/var/run/apache2/"
User: name="www-data" id=33
Group: name="www-data" id=33

1 Like

It's kinda weird to have a virtualhost for your nameservers hostname Perhaps you don't have a ServerName set?

My advice would be to configure a separate VirtualHost in a separate file for your main site.
Another option would be to use the webroot authenticator.

1 Like

I did try the webroot, specifying the path... The same error.... :frowning:

1 Like

What was the path? Exactly the same as the DocumentRoot of the correct VirtualHost?

1 Like

What correct VirtualHost?
I see only:

which doesn't match the requested name:

Although apache will serve some content regardless of an unmatched name, we are unable to see which document root would be served in this situation.
If that is all that was output, then we need to take a look at this file:
To confirm the document root matches your --webroot command.
And to also review it to see why the apache installer failed to work.

1 Like

Exactly the path to the DocumentRoot... I had no idea VirtualHost is such a mess... :slight_smile:

1 Like

Here is the file... As I can see, the path matches exactly....
<VirtualHost *:80>
ServerAdmin webmaster@localhost
DocumentRoot /var/www/html

	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined
1 Like

Please place a test file in the expected challenge folder:
[you need to create the complete path first, then create the test file]

mkdir /var/www/html/.well-known/
mkdir /var/www/html/.well-known/acme-challenge/
echo "just a test" > /var/www/html/.well-known/acme-challenge/test-1234

Then we try to access that test file from the Internet:

NOTE: Please don't change the name of the test file.
It is specifically without an extension on purpose [to simulate a real challenge file name]

1 Like

It's been done.
But, the URL is NOT
(medicalExpress is not hosted on my server, anymore.)
Nevertheless, I get

Not Found

The requested URL was not found on this server.
Apache/2.4.18 (Ubuntu) Server at Port 80
when I try to access that page...

The file is there...
administrator@ns1:~ ls -all /var/www/html/.well-known/acme-challenge/ total 12 drwxr-xr-x 2 root root 4096 Nov 26 17:34 . drwxr-xr-x 3 root root 4096 Nov 26 17:27 .. -rw-r--r-- 1 root root 12 Nov 26 17:34 test-1234 as you can see... And... administrator@ns1:~ cat /var/www/html/.well-known/acme-challenge/test-1234
just a test

1 Like

Then this problem has to be fixed first.

Please show the complete output of:
apachectl -S
[you may have to use sudo]
If it is the same as posted above, then you may need to include this short name in the file:
You can do this by adding a line after ServerName

Then restart Apache and retest access to the test-1234 file.

1 Like

Actually, given this bit of information:

You may want to replace all:

1 Like

There is no such directive in the virtualhost, the hostname is probably taken from the servers hostname.

1 Like

This seems to indicate otherwise:

1 Like

A configuration file has been pasted above, did you see that one?

1 Like