Wrong domain for SSL

Hi! I have a crazy "salad" with AWS instances, domains and SSL certificates. I hope you can help me :slight_smile: and thanks in advance.

My domain is emprendemy.online, and I used before emprendemy.guru

The thing is I created a separate instance in AWS Lightsail, exported site from .guru to .online, in the new instance (.online) removed the .guru SSL and created successfully the new one for .online.

Ok, perfect. But.... When I go to www.emprendemy.online it seems not secure, and in the certificate information it shows it is assigned to emprendemy.guru

Any ideas how can I solve it?


1 Like

This probably means your server configuration file have some old reference to the old certificate file. If you use Nginx, try sudo nginx -T and search for the certificate file. If you use Apache, try sudo apachectl -S

1 Like

Thanks for your reply! I got this:

AH00526: Syntax error on line 46 of /opt/bitnami/apache2/conf/bitnami/bitnami.conf:
SSLCertificateFile: file '/opt/bitnami/apache2/conf/server.crt' does not exist or is empty

1 Like


Have you tried to follow the instructions from Bitnami on this issue? Im not sure which acme client you use to configure the server, but looks like the server didn't apply the certificate (or didn't pickup the certificate via reload).

I would say to try install the certificate again (Install, do not reissue). And, the most important thing is, check if you run the commands in the wrong server.

Thanks @stevenzhu for your patience and help.

It is weird: I have 3 different instances, each of one associated to a different domain.

One domain is emprendemy.com, and it has a valid certificate until May 2. But when I run sudo openssl x509 -noout -dates -in /etc/letsencrypt/live/emprendemy.com/cert.pem to check the valid dates, I have different dates and no one shows May 2 :frowning:

So I run sudo certbot delete --cert-name emprendemy.com on the 3 instances (just to be sure) to delete all certificates associated to that domain, and the SSL is still there.

I cannot find WHERE is that certificate issued. Is there a way to understand where did I make that certificate?

Thanks again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.