Windows 7 & MDaemon: error installing the certificate


#1

Hello, greetings from Switzerland,

I have just migrated a MDaemon server on a brand new Windows 7 Pro machine and the creation of the certificate fails. Below is the the the log. Any suggestion ? Many thanks in advance ?

Yves

LOG


Starting Script run at 07/20/2017 16:32:30.
Get the MDaemon paths.
The MDaemon.ini Path is C:\MDaemon\App\MDaemon.ini.
The MDaemon APP Path is C:\MDaemon\App.
The MDaemon Pem path is C:\MDaemon\Pem.
The MDaemon Log path is C:\MDaemon\Logs.
The MDaemon RAW path is C:\MDaemon\Queues\Raw.
The WorldClient Path is C:\MDaemon\WorldClient.
The WorldClient HTML Path is C:\MDaemon\WorldClient\HTML.
The FQDN is set to md.bornick.ch.
The email address is set to postmaster@md.bornick.ch.
Importing the ACMESharp module.
Import-Module : Le module « ACMESharp » spécifié n’a pas été chargé, car aucun fichier de module valide n’a été trouvé dans un répertoire de module.
Au caractère C:\MDaemon\LetsEncrypt\letsencrypt.ps1:981 : 1

  • Import-Module ACMESharp -ErrorVariable LogText
  •   + CategoryInfo          : ResourceUnavailable: (ACMESharp:String) [Import-Module], FileNotFoundException
      + FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Commands.ImportModuleCommand
    
    

The script is stopping because an error occurred.


#2

hi @ybornick

What client are you using
What command are you running
Describe your setup rather than just pasting a log file (logs without context are not useful).
If you are following instruction from a wesbite paste the link so people can review.

Andrei


#3

Hi @ahaw021

Sorry for not having posted the right informations. I run a DOS-batch that launch a powershell script. The script is too long to be inserted here :frowning: I’ve uploaded both files on http://bornick.ch/letsencrypt.zip

My PC is Windows 7 Pro with PowerShell 4.0 Could it be the problem, too old OS ?

Thank you,

Yves


#4

hi @ybornick

No problems and thanks for taking the time to share the script as it helped resolve the problem (hopefully).

Are you aware that this script is using a library called ACMESharp?

I can’t see anywhere in the script where this is installed (maybe this was a step Alt-N missed)

MDaemon is a great product and the script looks pretty solid.

PowerShell 4 is fine.

Download and Install ACMESharp from here: https://github.com/ebekker/ACMESharp

Instructions: https://github.com/ebekker/ACMESharp/wiki/Quick-Start

Once ACMESharp is installed you should be able to call it as a module

The .bat file is a wrapper for the script but doesn’t install ACMESharp for you

Andrei


#5

Hi @ahaw021

Thank you for the reply. The problem is solved after installation of ACMESharp. Before that I had to install PowerShell 5.1 (KB3191566-x64) and Windows Management Framework 5.1 (KB3191566-x64) and the to type in PowerShell “Install-Module -Name PowerShellGet -Force” and then to type “Install-Module -Name ACMESharp”. After all that the MDaemon script worked fine :slight_smile:

Thank you very much for your help !

Yves


#6

thanks for the detailed write up :smiley:

glad everything is working for you

Andrei


closed #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.