Help With ACMESharp

Please fill out the fields below so we can help you better.

My domain is:parlocameoncorporation.com

I ran this command:Initialize-ACMEVault

It produced this output:Initialize-ACMEVault : The term ‘Initialize-ACMEVault’ is not recognized as the name of a cmdlet, function, script
file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct
and try again.
At line:1 char:1

  • Initialize-ACMEVault
  •   + CategoryInfo          : ObjectNotFound: (Initialize-ACMEVault:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException(does this for all acmesharp commands)
    
    

My web server is (include version):Nginx-1.13.2

The operating system my web server runs on is (include version):Windows 10

My hosting provider, if applicable, is:NONE

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):NO

HI, also, this was installed using PS> Install-Module -Name ACMESharp, and the version is 0.81. Powershell says this for all similar commands.

can you paste your script?

alternatively you can have a look at sample scripts: LE ACME-Exchange.ps1 Exchange 2016 Renewal issues

There are two possibilities from the symptoms you are describing:

A) The module was not installed correctly
B) The module was not imported in your script (you need to import modules)

Andrei

Didn’t really use a script @ahaw021. Just did the command listed above + Initialize-ACMEVault.
But how would I go about importing modules?

I was really just testing the basics, before I made anything big.

if you installed the package correctly you should be able to import it and then run the commands

Andrei

hi @Parlocameon

ACME-Sharp is a PowerShell Library which means you do need to be familiar with PowerShell to get the most out of it

If you are trying to use Let’s Encrypt on windows and are not comfortable to a medium level with powershell I would suggest using one of the other clients (your time is probably better spent learning those)

letsencrypt-winsimple


Certify

Andrei

@ahaw021 How would I go about that though? Used Install-Module, and according to Microsoft’s Technet, modules should be imported automatically on a command.

@ahaw021 Also, letsencrypt-winsimple does not work with Nginx, or subdomains, so I’m really kind of stuck here.

@ahaw021

Strange. Worked after I ran: Install-Module -Name “ACMESharp” -Force -Scope AllUsers -AllowClobber

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.