Windows 7 Backup Untrusted Certificate

Dear Team,
On another W10 Home rig, the Windows 7 Backup had no problem using the domain: However, the same process with the current machine running W10 Pro rejected the certificate through the DSM interface for reasons to be ascertained from this enquiry. No problem with, see below, but now the following new issue with the backup:

My domain is Synology DDNS:
I ran this command:
Windows 7 backup- please refer to
Windows 7 Backup on Synology: Smartcard Certificate Authority Untrusted
which produced this output:
COM error 0x80090352
The web server?
DSM 6.2.4-25556
The operating system my web server runs on is (include version):
W10 20H2


You may need to tweak the protocols and cipher settings on Win7.
Try using:
Nartac Software - IIS Crypto
[will likely require a reboot of the Win7 system]

Otherwise, you could try doing Windows Updates
Or installing this update (if not already installed):


Thanks, the rig itself happens to be W10, the backup attempted is known as Windows 7 backup (Run sdclt), not to be confused with the more recent OneDrive and File History backup systems (Run ms-settings:backup).
The most recent update from the link was for Win 8.1, not accepted by W10, unfortunately, The Nartac link is very interesting, Tried the "Best Practices" button, will post back on how we go after the reboot. :slight_smile:


The IIS Crypto settings fixed it! Thanks again for your help! :+1:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.