Window 10 Microsoft Edge doesn't recognize the certificate

My domain is:

My web server is (include version): WordPress 5.5.1

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): no

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): bitnami

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.31.0

Microsoft Edge 86.0.622.43 seems don't recognize this ssl certificate but it works fine on Chrome.


Welcome to the Let's Encrypt Community :slightly_smiling_face:

! Warning to all others trying to help: Bitnami WordPress stack present !

Your website has "mixed content' (content served over http inside your https-served webpage). You should be able to use the tool below to locate these issues.

You really want to disable TLSv1

  1. Set the SSLProtocol directive in /opt/bitnami/apache2/conf/bitnami/bitnami.conf to TLSv1.2:
    SSLProtocol TLSv1.2
  2. Restart Apache:
    /opt/bitnami/ restart apache

You've got some positively awful redirects that need fixed ASAP. You never want to redirect from https to http and the double forward slash (//) at the end really won't work.

Screenshot_20201019-165109_Samsung Internet

Screenshot_20201019-163947_Samsung Internet


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.