Win. ACME Client UriFormatException

The Web Management console for my 3CX Voip Server show SSL error because the certificate has expired. Like I would normally do, I ran the command to renew the cert. through Letsencrypt using windows ACME Client, but the Cert. generation process fails with the "Error UriFormatException { ... "
Nothing has changed on the server since my last renewal and countless other times.
I appreciate your assistance.

My domain is:
I ran this command:
PS C:\3CX\letsencrypt-win-simple.V1.9.2> .\letsencrypt.exe --renew

It produced this output:
Let's Encrypt (Simple Windows ACME Client)
Renewal Period: 60
Certificate Store: WebHosting
ACME Server:
Config Folder: C:\Users\mwebb\AppData\Roaming\letsencrypt-win-simple\
Certificate Folder: C:\Users\mwebb\AppData\Roaming\letsencrypt-win-simple\
Loading Signer from C:\Users\mwebb\AppData\Roaming\letsencrypt-win-simple\\Signer
Getting AcmeServerDirectory
Error UriFormatException {Message="Invalid URI: The URI scheme is not valid.", Data=, InnerException=null, TargetSite=
Void CreateThis(System.String, Boolean, System.UriKind), StackTrace=" at System.Uri.CreateThis(String uri, Boolean don
tEscape, UriKind uriKind)
at System.Uri..ctor(String uriString)
at ACMESharp.AcmeClient.GetDirectory(Boolean saveRelative)
at LetsEncrypt.ACME.Simple.Program.Main(String args)", HelpLink=null, Source="System", HResult=-2146233033}
Press enter to continue.

Would you like to start again? (y/n)

My web server is (include version):
Included in 3CX

The operating system my web server runs on is (include version):
Windows Server 2016
My hosting provider, if applicable, is:
3CX PBX Server

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Hi @mda.ssl

simple answer: ACME v1 is deprecated and currently blocked.


and switch to ACME v2.

I don't know in what version letsencrypt-win-simple added ACMEv2 support, but, @mda.ssl, you might need to switch to a newer version of your client software (now renamed from "letsencrypt-win-simple" to "win-acme").

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.