Wildcard: two domains, one works the other doesn't


#1

Hello, On Cloudflare, I have two domain configured exactly the same way. For one, I can issue a wildcard from Let’s Encrypt with no issue. For the other, I get this error:

Challenge failed for domain xxx
dns-01 challenge for xxx
Cleaning up challenges
Some challenges have failed.
IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: xxx
    Type: unauthorized
    Detail: No TXT record found at _acme-challenge.xxx

I am able to issue a regular certificate (using the web server to authenticate) without any issue. Its only the wildcard through the Cloudflare plugin that produces this problem and for only one domain. As mentioned, it is configured exactly the same way as another domain which works without any problems.


#2

Hi @babakness

we should know your domain name, so we can test that. Or use one of the online tools - https://check-your-website.server-daten.de/ - my tool, https://letsdebug.net/ - @_az

But without the domain name, it’s impossible to find the reason.


#3

Thanks @JuergenAuer, it somehow worked on it own. Not sure if its related to disabling the CDN cache or not; but after doing that and waiting for about an hour, it worked.