.well-known folder is not being created

Upon executing the command below certbot says that the connection timed out, but it should be able to connect just fine, as I manually created the folders afterwards. If I delete them, certbot doesn’t create any folders/files, so I think it could be a permission issue of sorts, but I couldn’t find any help online.

My domain is: cnmb10a.ddns.net

I ran this command: sudo certbot certonly --webroot -w /var/www/html/ -d cnmb10a.ddns.net

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for cnmb10a.ddns.net
Using the webroot path /var/www/html for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. cnmb10a.ddns.net (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://cnmb10a.ddns.net/.well-known/acme-challenge/mF-5M7qVPF2DLDwnu03GGxePaSPtlZ9mCddQ4uTf_gY: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: cnmb10a.ddns.net
    Type: connection
    Detail: Fetching
    http://cnmb10a.ddns.net/.well-known/acme-challenge/mF-5M7qVPF2DLDwnu03GGxePaSPtlZ9mCddQ4uTf_gY:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Apache/2.4.38 (Raspbian)

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Your site isn’t reachable from the world wide web in general. Not from my location and not from https://downforeveryoneorjustme.com/cnmb10a.ddns.net

Is the currently resolving IP address for that hostname 86.126.112.245 even correct?

1 Like

Thank you for your reply, the address is correct, it’s just that I haven’t thought of testing it from outside the local network, where it works just fine. I will look for the issue there and update if it’s still not working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.