Website not working

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command: today

It produced this output: this connection is not private

My web server is (include version):

The operating system my web server runs on is (include version): godaddy is domain provider

My hosting provider, if applicable, is: carrd

I can login to a root shell on my machine (yes or no, or I don't know):
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Please help. My website was working fine for a while but now it is not. My website is on carrd but the domain is godaddy. The ssl will not initialize. I am brand new to this and very lost.thank you

I don't mean to be dismissive but I think you should contact ccard directly.

They look like a full-service hoster who handles the certificates for you. I can see they use some sort of CDN or Load Balancer with Amazon services.

Their topic below says new sites will setup automatic but you may need to wait a bit. Is it a brand new site at ccard?


No I have had it since July and it just started doing this. I contacted carrd but it’s hard to get a hold of anyone.

Maybe that tells you to look for a better hosting service?

Perhaps a different volunteer may have ideas but requests to your domain are sending out a self-signed cert for some AWS EC2 instance. I really don't think we can do anything about that.

Do you have control of the Apache server that your domain's DNS points to?

Do you know why there are 2 IP addresses in your DNS pointing to AWS EC2?


Unfortunately I do not

1 Like

What was the command you ran?

Mostly to me it seems that the TLS (i.e. SSL) certificate is just some self signed certificate
see SSL Checker and Hardenize: Comprehensive web site configuration test

Yet certificates have been issued for the domain in the past see |

Using curl it seems your web server is: Apache

$ curl -Ii
HTTP/1.1 301 Moved Permanently
content-length: 0
$ curl -k -Ii
HTTP/1.1 404 Not Found
date: Thu, 09 Nov 2023 01:54:49 GMT
server: Apache
content-type: text/html; charset=iso-8859-1
1 Like

Yea it worked totally fine in the past and now its not.

What is a self signed certificate and why did it change to that?

I ran the website today, is that what it meant

What has changed since the site was working?


see Self-signed certificate - Wikipedia

Not sure, that's why I am trying to understand what has changed.

2 Likes is now saying initializing on the carrd website which is odd bc I never changed anything.

Could someone have hacked it?

I would recommend, as did @MikeMcQ, look for a better hosting service.

I cannot even get the verification email "Your account needs to be verified! Instructions have been sent to"

1 Like

Also from here Setting up SSL - Sites - Documentation - Carrd

For Custom Domains (and Subdomains)

An SSL certificate will be automatically issued (via Let's Encrypt) once the host records for the site's domain or subdomain are in place and have fully propagated. Note that this process can sometimes take up to an hour to complete (depending on your domain or DNS provider), but if it takes any longer please get in touch.

1 Like

@Kay I am getting the same results presently for

But using a subdomain under their domain works fine.

PS - my test site is boring :yawning_face:


It is a sign. If OP cant login to his own service.. There is an issue.
@Kay , with all due respect... Please look at other hosting providers.
It is impossible to assist you here if you cant even access your own stuff.

This is an issue.
Listen to @MikeMcQ and @Bruce5051 and find a suitable hosting company.


It seems currently the certificate has "magically" (?) been renewed and looks like the site is secured again. Not sure what happened (obviously).

Looking at the duplicate cert at | it seems the hosting provider has done something manually :roll_eyes:


Thank you all for your help. Carrd did fix it but I’m going to ask them why this randomly happened bc its concerning. Thank you for the recommendations


Indeed; What have they done to insure it won't happen again?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.