Webroot changed when use $ certbot --apache


#1

Hi every one , I am new for the certbot , I use $ certbot --apache changed my web site from http to https. it worked , but the thing is , after I execute this “$ certbot --apache” my webroot change from var/lib/tomcat8/webapps/ to var/www/html
what I want to know is how I can deploy .war package this time ,I used to put it under var/lib/tomcat8/webapps/ but now since the webroot path changed it doen’t work anymore .
I used to save my war package to ROOT.war and place it under var/lib/tomcat8/webapps/

or is there anyway I can undo my change , and go back to the way they were ?

ps.when I use certbot --apache I chose only 443 .
tomcat8
apach2
ubuntu16.10


#2

@chnchyl

The obvious question that comes to mind - why are you using the Apache command (designed for Apache web servers) with a Tomcat server?

ps.when I use certbot --apache I chose only 443 .

This is how the specification and client are written. You have very little control over that.

If you could explain your setup it may help you get more meaningful hesitance (remember we don’t know your configurations or setups)

Andrei


#3

Hi @ahaw021,
among those list , apache is the only familiar words , thank you reply me , I got some help and the problem solved , just do some configuration on the apache and then it redirect the request to tomcat .


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.