Webgo Hosting Provider - No SUDO Means Certbot Cannot Run - Need to Use Another Client

Please fill out the fields below so we can help you better.

My domain is: twin-business.com

I ran this command: ./certbot-auto

It produced this output:
“sudo” is not available, will use “su” for installation steps…
Sorry, I don’t know how to bootstrap Certbot on your operating system!

You will need to install OS dependencies, configure virtualenv, and run pip install manually.
Please see https://letsencrypt.readthedocs.org/en/latest/contributing.html#prerequisites for more info.

My web server is (include version): Apache 2, PHP 7.1

The operating system my web server runs on is (include version): Debian 3.2

My hosting provider, if applicable, is: http://webgo.de

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): wordpress

Here is the problem. I really am not into the topic of this, but I need to get a SSL certificate.
Can anyone help me? Step-by-step?

You can try to run certbot-auto as the root user. That would bypass the check for sudo or su.

I don’t have root access…


But in that case, certbot probably isn't the most practical choice.

Doesn't your provider offer a control panel like cPanel, besides Wordpress?

Yeah, sorry. I noticed later that in fact I don’t have any access to a root shell. It offers a control panel where I can do Apache entries. But i couldn’t find a tut on how to do it this way.

You might want to be a liiiiitle more specific than that if you want further help. We don't have crystal balls to actually know what you mean by that.

For example, it might work to manually get a certificate with one of the third party clients (mostly the bash clients are useful, I would recommend acme.sh for ease of use and many DNS plugins) and install the certificate manually with your panel. But I can't tell you if it would actually work because of lack of information about the panel.

It looks like this the control panel. And I also have access over SSH.

hi @TBGB

You are using a hosting provider https://www.webgo.de/ssl/

It’s highly likely that you will not have root access as it looks like it is a shared plan (lots of people using the same server)

I would investigate another client as suggested by @Osiris


I tried the client “dehydrated” and which doesn’t need root access. When I try config it, there comes the error “ERROR: Not running in CI environment!”.

I have no idea what that error means.

Luckily, there are a few more bash clients to try :stuck_out_tongue:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.