Virtual environment error

I tried to get SSL-certificates for my Nextcloud but it failed

Background Information:

  • Platform: RaspberryPi 3
  • OS: Raspbian Stretch with desktop Version: April 2019
  • Server version: Apache/2.4.25 (Raspbian)

What I did:

  • wget
  • sudo mv certbot-auto /usr/local/bin/certbot-auto
  • sudo chown root /usr/local/bin/certbot-auto
  • sudo chmod 0755 /usr/local/bin/certbot-auto
  • sudo /usr/local/bin/certbot-auto --apache

The Result:

Creating virtual environment…
Installing Python packages…
Had a problem while installing Python packages.
pip prints the following errors:

Collecting ConfigArgParse==0.14.0 (from -r /tmp/tmp.4O2gT0JHhV/letsencrypt-auto-requirements.txt (line 7))
Collecting asn1crypto==0.24.0 (from -r /tmp/tmp.4O2gT0JHhV/letsencrypt-auto-requirements.txt (line 9))
Downloading (101kB)
Collecting certifi==2019.3.9 (from -r /tmp/tmp.4O2gT0JHhV/letsencrypt-auto-requirements.txt (line 12))
Downloading (158kB)
Collecting cffi==1.12.2 (from -r /tmp/tmp.4O2gT0JHhV/letsencrypt-auto-requirements.txt (line 15))

Downloading a lot more…

Requirement already satisfied: setuptools>=1.0 in /opt/ (from josepy==1.1.0->-r /tmp/tmp.4O2gT0JHhV/letsencrypt-auto-requirements.txt (line 87))
THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the package versions, please update the hashes. Otherwise, examine the package contents carefully; someone may have tampered with them.
pycparser==2.19 from (from -r /tmp/tmp.4O2gT0JHhV/letsencrypt-auto-requirements.txt (line 105)):
Expected sha256 a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3
Got 344870c533812cb119c5475b5aed033ec546118711338ff9b2b78e67098d64e7

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip

for possible solutions.
You may also find some support resources at .

(dont know why the text is so thick…)

I also tried:

  • sudo fallocate -l 1G /tmp/swapfile
  • sudo chmod 600 /tmp/swapfile
  • sudo mkswap /tmp/swapfile
  • sudo swapon /tmp/swapfile

Thank you for your help I am a F*cking Nohand

Best Regards from Germany

Hi @JR-Nohand

please check

and some other topics with the same problem.

1 Like

Danke Jürgen!
Ich schau mir das mal an und hoffentlich ist was dabei!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.