Verify the domain


#1

HI there.
I have tried to add a new domain via
./letsencrypt-auto certonly -a manual --rsa-key-size 4096 -d www.bjoern-deutschmann.photography

But after that I have gotten the error:

Failed authorization procedure. www.bjoern-deutschmann.photography (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Could not connect to http://www.bjoern-deutschmann.photography/.well-known/acme-challenge/Iih6j5hnhHe4X5aJR-HKQILnc4d97ymDKhwA69XJu_Y

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: www.bjoern-deutschmann.photography
Type: connection
Detail: Could not connect to
http://www.bjoern-deutschmann.photography/.well-known/acme-challenge/Iih6j5hnhHe4X5aJR-HKQILnc4d97ymDKhwA69XJu_Y

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

What does that mean and how can I fix that? DNS A records are corret, also IP and so on. I use already several certificate on the server for different domains like bjoern-deutschmann.de
Renewal of the existing certificates are no problems.

Have also tried it via Plesk, but the same:

Failed authorization procedure. bjoern-deutschmann.photography
(http-01): urn:acme:error:connection :: The server could not connect to
the client to verify the domain :: Could not connect to
http://bjoern-deutschmann.photography/.well-known/acme-challenge/mxcWeniWRSdGHBVnrnFIlakzhn_rRYohndxJWP9wpT0,
www.bjoern-deutschmann.photography (http-01): urn:acme:error:connection
:: The server could not connect to the client to verify the domain ::
Could not connect to
http://www.bjoern-deutschmann.photography/.well-known/acme-challenge/HCcgl_CxA6aorAisoJFMyquz80JJJwlK_R3zda0i2Aw

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: bjoern-deutschmann.photography

Type: connection

Detail: Could not connect to

http://bjoern-deutschmann.photography/.well-known/acme-challenge/mxcWeniWRSdGHBVnrnFIlakzhn_rRYohndxJWP9wpT0

Domain: www.bjoern-deutschmann.photography

Type: connection

Detail: Could not connect to

http://www.bjoern-deutschmann.photography/.well-known/acme-challenge/HCcgl_CxA6aorAisoJFMyquz80JJJwlK_R3zda0i2Aw

To fix these errors, please make sure that your domain name was

entered correctly and the DNS A record(s) for that domain

contain(s) the right IP address. Additionally, please check that

your computer has a publicly routable IP address and that no

firewalls are preventing the server from communicating with the

client. If you’re using the webroot plugin, you should also verify

that you are serving files from the webroot path you provided.

What can I do?


#2

In order to pass this challenge, the server behind your domain has to listen on port 80 on the public internet (as opposed to, for example, just your LAN/intranet).

I’m currently unable to connect:

telnet www.bjoern-deutschmann.photography 80
Trying 31.220.127.129...
telnet: connect to address 31.220.127.129: Connection refused

Make sure that you’re running a web server on port 80 and that your firewall allows access to it.


#3

okay, solved… had to copy a special file to the domain directoy to proof the ownership…

printf "%s" V_aEI_idIS43tut0k0lxRx-s8l6dL56AUtTSc4WYBuA.sPQgefyDHxKPoWPkt0xmAa-9OM5JCR27_AdRHes7c-A > .well-known/acme-challenge/V_aEI_idIS43tut0k0lxRx-s8l6dL56AUtTSc4WYBuA


#4

Yeah, maybe because I have tested and so on and turned off apache and ngnx


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.