Valid certificate but still not secure

I installed and activated the certificate and it shows valid certificate but site is still not secure.
My domain is:
My hosting provider, if applicable, is: cPanel
I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cPanel

1 Like

Hi @farza

checking your domain there is no problem visible -

You have created one certificate with both domain names:

Issuer not before not after Domain names LE-Duplicate next LE
Let's Encrypt Authority X3 2019-12-06 2020-03-05, - 2 entries duplicate nr. 1

And you use that certificate:
expires in 90 days, - 2 entries

There is no mixed content.

Some smaller things, Grade E, Grade B should be possible. But it's not a Grade N (wrong certificate, expired ...) or I (mixed content).

PS: Do you have a screenshot?

1 Like

Is it not right to have one certificate for two domains ? Actually they are same , one with www and other without it.

I checked the website on windows without admin login , and it came as secured. Is it some problem with admin or with mac?
Here is the screen shot of ‘not secure’ screen.

That's ok, that's not the problem.

Looks like your admin account has additional objects, so you have a mixed content.

I don't use mac. Is there a console (Ctrl + Shift + I)? Or is it possible to open the site (as admin) with a Chrome or FireFox? Then use Ctrl + Shift + I to check, if there are additional informations.

Online tools are not logged in -> so it's impossible to check that with online tools.

1 Like

I checked the console on mac. Here is image of console opened with admin login.

What says “Security”? There must be an error.

But sometimes browsers show incomplete sources of mixed content.

Is it https?

yes, it is https. Website is coming fine on safari too. It is on chrome where it keeps on showing not secure.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.