Using Letsencrypt with a java spring-boot application


#1

I’m developing my site (mi16s.ru) and trying to establish secure connection to it.
My hosting provider provide me with Debian 9 stretch server with SSH access.
I use nginx as a web server, and tomcat8 as application server.
For secure access I installed certbot package.

For static HTML pages everything works fine. When I try to open the site by typing mi16s.ru as URL, the site is opened over secure connection as https://mi16s.ru

I also developed a java spring-boot application, built it as phog.war file and installed the file into /var/lib/tomcat8/webapps directory
When I try to open the application by typing mi16s.ru:8080/phog it is opend over unsecure connection as http://mi16s.ru:8080/phog/

Now I want to configure my site so that not only staic pages (e.g. /var/www/html/index.html) are opened over secure connection, but dynamic spring-boot applications (e.g. /var/lib/tomcat8/webapps/phog.war) will be opened over secure connection either.
I create file /etc/letsencrypt/live/mi16s.ru/bundle.pfx
and add the following lines into file /etc/nginx/sites-enabled/default:
server {
listen 80;
listen [::]:80;
server_name mi16s.ru;

      location / {
        proxy_pass http://127.0.0.1:8080;
        proxy_set_header Host      $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header X-Forwarded-Proto $scheme;
    }
}

But again the application is opened only over unsecure connection.
If I try to open it by typing https://mi16s.ru:8080/phog/ I get an error message: “An error occurred during a connection to mi16s.ru:8080. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG”
If I try to open it by typing https://mi16s.ru/phog/ I get an error message: “404 Not Found”

I noticed that file /etc/letsencrypt/live/mi16s.ru/bundle.pfx is owned by root and has mode: 600, trying to change its mode to 644 does nothing.

I noticed also, that when I run the command: “systemctl restart nginx” I get error messages in file /var/log/nginx/error.log:
conflicting server name “mi16s.ru” on 0.0.0.0:80, ignored
conflicting server name “mi16s.ru” on [::]:80, ignored
I don’t understand what these messages mean, but think there is something wrong in my file /etc/nginx/sites-enabled/default, so here it is all:

##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# https://www.nginx.com/resources/wiki/start/
# https://www.nginx.com/resources/wiki/start/topics/tutorials/config_pitfalls/
# https://wiki.debian.org/Nginx/DirectoryStructure
#
# In most cases, administrators will remove this file from sites-enabled/ and
# leave it as reference inside of sites-available where it will continue to be
# updated by the nginx packaging team.
#
# This file will automatically load configuration files provided by other
# applications, such as Drupal or Wordpress. These applications will be made
# available underneath a path with that package name, such as /drupal8.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#
server {
	listen 80 default_server;
	listen [::]:80 default_server;

	# SSL configuration
	#
	# listen 443 ssl default_server;
	# listen [::]:443 ssl default_server;
	#
	# Note: You should disable gzip for SSL traffic.
	# See: https://bugs.debian.org/773332
	#
	# Read up on ssl_ciphers to ensure a secure configuration.
	# See: https://bugs.debian.org/765782
	#
	# Self signed certs generated by the ssl-cert package
	# Don't use them in a production server!
	#
	# include snippets/snakeoil.conf;

	root /var/www/html;

	# Add index.php to the list if you are using PHP
	index index.html index.htm index.nginx-debian.html;

	server_name _;

	location / {
		# First attempt to serve request as file, then
		# as directory, then fall back to displaying a 404.
		try_files $uri $uri/ =404;
	}

	# pass PHP scripts to FastCGI server
	#
	#location ~ \.php$ {
	#	include snippets/fastcgi-php.conf;
	#
	#	# With php-fpm (or other unix sockets):
	#	fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
	#	# With php-cgi (or other tcp sockets):
	#	fastcgi_pass 127.0.0.1:9000;
	#}

	# deny access to .htaccess files, if Apache's document root
	# concurs with nginx's one
	#
	#location ~ /\.ht {
	#	deny all;
	#}
}

# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#	listen 80;
#	listen [::]:80;
#
#	server_name example.com;
#
#	root /var/www/example.com;
#	index index.html;
#
#	location / {
#		try_files $uri $uri/ =404;
#	}
#}

server {

	# SSL configuration
	#
	# listen 443 ssl default_server;
	# listen [::]:443 ssl default_server;
	#
	# Note: You should disable gzip for SSL traffic.
	# See: https://bugs.debian.org/773332
	#
	# Read up on ssl_ciphers to ensure a secure configuration.
	# See: https://bugs.debian.org/765782
	#
	# Self signed certs generated by the ssl-cert package
	# Don't use them in a production server!
	#
	# include snippets/snakeoil.conf;

	root /var/www/html;

	# Add index.php to the list if you are using PHP
	index index.html index.htm index.nginx-debian.html;
    server_name mi16s.ru; # managed by Certbot

	location / {
		# First attempt to serve request as file, then
		# as directory, then fall back to displaying a 404.
		try_files $uri $uri/ =404;
	}

	# pass PHP scripts to FastCGI server
	#
	#location ~ \.php$ {
	#	include snippets/fastcgi-php.conf;
	#
	#	# With php-fpm (or other unix sockets):
	#	fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
	#	# With php-cgi (or other tcp sockets):
	#	fastcgi_pass 127.0.0.1:9000;
	#}

	# deny access to .htaccess files, if Apache's document root
	# concurs with nginx's one
	#
	#location ~ /\.ht {
	#	deny all;
	#}


    listen [::]:443 ssl ipv6only=on; # managed by Certbot
    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/mi16s.ru/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/mi16s.ru/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}
server {
    if ($host = mi16s.ru) {
        return 301 https://$host$request_uri;
    } # managed by Certbot


	listen 80 ;
	listen [::]:80 ;
    server_name mi16s.ru;
    return 404; # managed by Certbot

}

server {
        listen 80;
        listen [::]:80;
        server_name mi16s.ru;

        location / {
                proxy_pass http://127.0.0.1:8080;
                proxy_set_header Host      $host;
                proxy_set_header X-Real-IP $remote_addr;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_set_header X-Forwarded-Proto $scheme;
        }
}

Can anybody help me to configure secure access to my application.
Thank you, Mikhail.


How can i install letsencrypt ssl on java app
#2

Hi @mr16

I moved your question to a new topic, makes it easier.

Your error

says: Your port 8080 sends http content. Checked your domain / port with my tool ( https://check-your-website.server-daten.de/?q=mi16s.ru%3A8080 ), there you see the error:

Domainname Http-Status redirect Sec. G
http://mi16s.ru:8080/
78.24.221.106 200 0.134 H
http://www.mi16s.ru:8080/
78.24.221.106 200 0.117 H
https://mi16s.ru:8080/
78.24.221.106 -4 0.224 W
SendFailure - The underlying connection was closed: An unexpected error occurred on a send. The handshake failed due to an unexpected packet format.
https://www.mi16s.ru:8080/
78.24.221.106 -4 0.217 W
SendFailure - The underlying connection was closed: An unexpected error occurred on a send. The handshake failed due to an unexpected packet format.

That’s a correct http port.

I’m not so firm with Tomcat. But there are additional steps required that you can use a certificate with tomcat (saving the certificate in a format so you can import it in a java key store).

I don’t see the port in your nginx config. So it’s only a thing of your tomcat. But you can reuse the same certificate.


#3

PS:

You have two listen 80 / listen [::]:80 directives with the same server name

So one is ignored. Perhaps remove (comment) the first.


#4

Hi JuergenAuer,
Thank you for your answer.

At first I wanted to establish web site with both static (HTML pages) and dynamic (spring-boot application) content. But then I saw the task was too complicated (for me).
So I decided that my server would support only my spring-boot application, no static HTML pages. I rebuild my application as JAR file and configure the site as
gamujtaba explains in his “How can i install letsencrypt ssl on java app” messages.

Now all works fine.

Mikhail

PS
Perhaps later when I gain more experience I will add static HTML pages support to my site too.


closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.