Unable to Verify Wildcard and Base Domain together


#1

I got a Wildcard Certificate at sslforfree.com but it doesn’t works without subdomain.

the domain is parveenbhadoo.com

the ssl works for www.parveenbhadoo.com and all other subdomains, but shows error on parveenbhadoo.com i.e. without www. I cannot verify both at the same time.


#2

You need to include both parveenbhadoo.com and *.parveenbhadoo.com on the certificate.

I can recommend using zerossl.com or https://gethttpsforfree.com instead, they are both more secure anyway.


#3

Zerossl doesn’t supports wildcard yet.

says

Domain names seem to contain odd characters.


#4

You are right, my apologies, ZeroSSL support is coming soon.

At sslforfree, there is a solution documented:

For example to create a wildcard domain for example.org enter *.example.org example.org. To create a wildcard certificate for multiple domains such as example.org and example.com enter *.example.org example.org *.example.com example.com. Manual DNS verification will be required

Did you try that?

https://www.sslforfree.com/create?domains=parveenbhadoo.com+*.parveenbhadoo.com

For other client options, what OS are you on? I know that ZeroSSL provides a portable Windows client that supports wildcards, and if you are on macOS or Linux, you can use Certbot in --manual mode to issue a certificate from your computer.


#5

I am guessing these instructions on the site here are backwards and messing people up?


#6

Thanks for this! Just made my first wildcard domain, worked perfectly! On to number 2! :slight_smile:


#7

I did, but at verification it shows error in incorrect TXT records. because it says for acme-challenge.domain.org for both TXT records it messes up and says incorrect. because of the same challenges.


#8

Did you create both TXT records and wait some seconds? Exactly what DNS records existed? What happened? What error message was reported?


#9

@parveenbhadoo If you run this test that is on their site https://www.sslforfree.com/create?dns_txt_verify=_acme-challenge.parveenbhadoo.com

It says No TXT Record Found so it doesn’t look like you made them to me. Have you added the TXT records they gave you to the DNS yet?


#10

What hosting provider did u use?
Do u have access to a cpanel?


#11

Problem solved as last time it was showing two verifications in sslforfree, but they fixed the problem as it is working. I just created a certificate.


#12

What do you mean they want to verify you with two verification, I mean that it is what it do you must verify *.example.com and example.com.
I even succeed by using this dns verification.


#13

I mean it was showing two different links to verify both dns and when we do the TXT records with switching to each other as the system doesn’t know which one is wildcard and which one is for other. Now the problem is fixed as i can see. The dns verification finds 2 records no matter in which order they are displayed. It works if it finds two given TXT records. As you can see in screenshot.


#14

Oh, I understand! :grinning:


#15

It is actually there, I’m just not completely satisfied with the implementation yet :slight_smile: Here’s the link to a FAQ section which points to a version supporting wildcards: Beta client supporting wildcards.

It is still work in progress and the feedback is welcomed.


#16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.