Unable to Renew Certificate

#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: bwis.online

I ran this command: sudo certbot renew --dry-run

It produced this output:

Saving debug log to /uar/log/letsencrypt/letsencrypt.log
Processing 'etc/ letsencrypt/renewal/bwis.online.conf
Cert is due for renewal, auto—renewing …
Plugins selected: authenticator apache, Installer apache
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for bwis.online
http-01 challenge for www.bwis.online
Waiting for verification.
Cleaning up challenges
Attempting to renew cert (bwis.online) from /etc/letsencrypt/renewal/bwis.online.conf produced an unexpected error: Failed authorization procedure. bwis.onl ine (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from https://www.bwis.online/404.php [213.219.37.212]: Skipping.
All renewal attempts failed. The following certs could not be renewed : /etc/letsencrypt/live/bwis.online/fulIchain.pem (failure)

DRY RUN: simulating ‘certbot renew’ close to cert expiry (The test certificates below have not been saved. )

All renewal attempts failed. The following certs could not be renewed : /etc/letsencrypt/live/bwis.online/fulIchain.pem (failure) DRY RUN: simulating ’ certbot renew’ close to cert expiry (The test certificates above have not been saved . )
1 renew failure(s), 0 parse failure(s)

IMPORTANT NOTES :
The following errors were reported by the server :
Domain: bwis.online
Type: unauthorized
Detail: Invalid response from https://www.bwis.online/404.php [213.219.37.212]:

To fix these errors, please make sure that your domain name was entered correctly and the DNS record (s) for that domain contain(s) the right IP address .

My web server is (include version): Apache 2.4.18 (Ubuntu)

The operating system my web server runs on is (include version): Ubuntu 16.0.4.6 LTS

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.28.0

I’ve renewed using the existing settings before successfully without any issues but for some reason it isn’t having it this time. I can also place files in the .well-known/acme-challenge folder and access them online (https://www.bwis.online/.well-known/acme-challenge/1234 is there currently). Permissions on those folders are 755.

I’ve seen a few people mentioning IPv6 on here, saying that you can’t have those in your DNS if you don’t have the config. I’ve removed those. I’ve also added a CAA entry although I don’t think that was related. I’ve also noticed some people saying it’s now done on port 80, but it seems to be redirecting to 443 ok (I have redirects setup in my apache config). Any ideas?

UPDATE - I’ve just updated certbot to 0.31.0 and I still get the same output

#2

Hi @pmanington

is that file empty? If yes, add something - “Hello World” - to see, if the file is correct.

If that works, you have found your correct webroot.

Then use it:

certbot run -a webroot -i apache -w thisWebRoot -d bwis.online -d www.bwis.online

There is a check of your domain ( https://check-your-website.server-daten.de/?q=bwis.online ).

The redirect to /404.php may be skipped if the file exists.

1 Like
#3

Hi Juergen.

That worked perfectly. I did try something similar to that before and it failed so I’m not sure whether something I did since then fixed it or not, but I can’t thank you enough :slight_smile:

Cheers

1 Like
closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.