Unable to renew certificate

Hey community,
I was trying to renew my certificate following this document. I started from the fifth step but I realized that I didn’t have the “lego” installed, so I started again from step.1 to step.4. From my understanding, I have generated a new certificate for my domain after finishing step1~4. I tried to run the renewal command line showing below and the result was not fail due to the remaining 89 days until expired. Then I went to the browser to check the certificate, it showed there are only 19 days until expired, which means I didn’t successfully renew the certificate. So now I’m confused about this, the server is not allowing me to renew it but the browser says it’s about to expire. Could anyone please help me on this issue? Thank you!

My domain is:

I ran this command:
sudo /opt/bitnami/ctlscript.sh stop
sudo lego --tls --email="c.yang@easycookasia.de" --domains=“easycookasia.de” --path="/etc/lego" renew

It produced this output:
The certificate expires in 89 days, the number of days defined to perform the renewal is 30: no renewal.

Hi @marcusssss

looks like both is true.

The Letsencrypt certificate of your website ( https://check-your-website.server-daten.de/?q=easycookasia.de ):

expires in 20 days	easycookasia.de, www.easycookasia.de - 2 entries

Your certificates:

CRT-Id Issuer not before not after Domain names LE-Duplicate next LE
1363602945 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2019-04-08 10:44:40 2019-07-07 10:44:40 easycookasia.de, www.easycookasia.de duplicate nr. 1
1151835230 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2019-01-28 09:15:53 2019-04-28 08:15:53 easycookasia.de, www.easycookasia.de

So you have created a new certificate. But it isn't installed.

Check the Bitnami documentation to install the certificate.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.