Unable to login (Glassfish admin) after enbling let's encrypt Cert


#1

hello, i was trying to enable lets encrypt certificate on my web app which is deployed on Glassfish server (www.brain-booster.link).
The script i ran to do so was :

DOMAIN=brain-booster.link
KEYSTOREPW=the_password
GFDOMAIN=/home/yourUsername/glassfish4/glassfish/domains/domain1
LIVE=/etc/letsencrypt/live/$DOMAIN

sudo openssl pkcs12 -export -in $LIVE/cert.pem -inkey $LIVE/privkey.pem -out cert_and_key.p12 -name myalias -CAfile $LIVE/chain.pem -caname root -password pass:$KEYSTOREPW
sudo keytool -importkeystore -destkeystore keystore.jks -srckeystore cert_and_key.p12 -srcstoretype PKCS12 -alias myalias -srcstorepass $KEYSTOREPW -deststorepass $KEYSTOREPW -destkeypass $KEYSTOREPW
sudo keytool -import -noprompt -trustcacerts -alias root -file $LIVE/chain.pem -keystore keystore.jks -srcstorepass $KEYSTOREPW -deststorepass $KEYSTOREPW -destkeypass $KEYSTOREPW

sudo openssl pkcs12 -export -in $LIVE/fullchain.pem -inkey $LIVE/privkey.pem -out pkcs.p12 -name glassfish-instance -password pass:$KEYSTOREPW
sudo keytool -importkeystore -destkeystore keystore.jks -srckeystore pkcs.p12 -srcstoretype PKCS12 -alias glassfish-instance -srcstorepass $KEYSTOREPW -deststorepass $KEYSTOREPW -destkeypass $KEYSTOREPW
sudo openssl pkcs12 -export -in $LIVE/fullchain.pem -inkey $LIVE/privkey.pem -out pkcs.p12 -name s1as -password pass:$KEYSTOREPW
sudo keytool -importkeystore -destkeystore keystore.jks -srckeystore pkcs.p12 -srcstoretype PKCS12 -alias s1as -srcstorepass $KEYSTOREPW -deststorepass $KEYSTOREPW -destkeypass $KEYSTOREPW

sudo keytool -list -keystore keystore.jks -storepass $KEYSTOREPW

sudo cp -f keystore.jks $GFDOMAIN/config/

sudo service glassfish stop
sudo service glassfish start
######### END OF FILE ##########
the script executed without any errors. The when tried to connect to the glassfish admin console using this adress (www.brain-booster.link:4848) i can see https enable but when i type my login and password, glassfih does returns a blank page…
The OS i use centos 7 (VPS server of a2hosting).

Really need help, thanks !


#2

Hi @n9tcrack,

Your certificate seems valid and your HTTPS connection seems secure, so I think this is a Glassfish configuration problem. (It may well be related to the use of HTTPS in some way, but not really to Let’s Encrypt.)

In the past, I haven’t seen very many people on this forum who are familiar with Glassfish, so I would suggest trying your question on a more Glassfish-related forum.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.