Certboot connection refused

This domain has been running Glassfish on http, I want to change to https.

My domain is:

I ran this command:
/usr/local/bin/certbot-auto certonly --standalone

It produced this output:
/opt/eff.org/certbot/venv/local/lib/python2.7/site-packages/cryptography/hazmat/bindings/openssl/binding.py:163: CryptographyDeprecationWarning: OpenSSL version 1.0.1 is no longer supported by the OpenSSL project, please upgrade. The next version of cryptography will drop support for it.
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Enter email address (used for urgent renewal and security notices)
(Enter ‘c’ to cancel): <my e-mail>@gmail.com

Please read the Terms of Service at
https://letsencrypt.org/documents/LE-SA-v1.2-November-15-2017.pdf. You must
agree in order to register with the ACME server at

(A)gree/©ancel: A

Would you be willing to share your email address with the Electronic Frontier
Foundation, a founding partner of the Let’s Encrypt project and the non-profit
organization that develops Certbot? We’d like to send you email about our work
encrypting the web, EFF news, campaigns, and ways to support digital freedom.

(Y)es/(N)o: Y
Please enter in your domain name(s) (comma and/or space separated) (Enter ‘c’
to cancel): algstoch.eu
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for algstoch.eu
Waiting for verification…
Challenge failed for domain algstoch.eu
http-01 challenge for algstoch.eu
Cleaning up challenges
Some challenges have failed.


  • The following errors were reported by the server:

    Domain: algstoch.eu
    Type: connection
    Detail: Fetching
    Connection refused

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

  • Your account credentials have been saved in your Certbot
    configuration directory at /etc/letsencrypt. You should make a
    secure backup of this folder now. This configuration directory will
    also contain certificates and private keys obtained by Certbot so
    making regular backups of this folder is ideal.

My web server is (include version):
Glassfish 4.1, I stopped it temporarily in order to run certbot

The operating system my web server runs on is (include version):
Raspbian 8, based Debian

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT tcp – anywhere anywhere tcp dpt:http
ACCEPT tcp – anywhere anywhere tcp dpt:http-alt

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

# ip6tables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

What port and address is Glassfish bound to, when it’s running?

netstat -tlnp

I ask because generally Java application servers run on non-privileged ports, unlike UNIX-y webservers who bind to 80 and then drop privileges. What I’m looking for is if there is some port redirection going on.

Speculative suggestion: if Glassfish runs on 8080, you could try run Certbot on the same port with an additional flag:

--http-01-port 8080

Yes, you have given the exact solution. I did not touch this configuration for a long time, there was port forwarding.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.