Unable to locate credentials

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:hqyc1973.com

I ran this command:sudo certbot certonly --dns-route53 --dns-route53-propagation-seconds 30 -d from-dawn.com --agree-tos -m myemail@greatmail.com -n

It produced this output:Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator dns-route53, Installer None
Requesting a certificate for from-dawn.com
Performing the following challenges:
dns-01 challenge for from-dawn.com
Cleaning up challenges
Unable to locate credentials
To use certbot-dns-route53, configure credentials as described at https://boto3.readthedocs.io/en/latest/guide/configuration.html#best-practices-for-configuring-credentials and add the necessary permissions for Route53 access.

My web server is (include version):Cherrypy

The operating system my web server runs on is (include version):Ubuntu 18.04 LTS

My hosting provider, if applicable, is:AWS

I can login to a root shell on my machine (yes or no, or I don't know):yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):certbot 1.14.0

I've followed the tutorial and put my access key into ~/.aws/config
I'm pretty sure that this config is accessible from the sudo command. However it still report error. Kind of scratching my head and couldn't figure out what's going wrong?

If it's run as sudo, it probably has to be in root's .aws directory. If you run sudo -i to get a shell as root, you should then be able to ls ~/.aws/config and ensure that it's there.

Just tried this, but for some reason it still doesn't work. I'll do some research online and if I find a solution I'll post here.

You may also want to explore setting the AWS_CONFIG_FILE environment variable directly, or using EC2's instance roles so that you don't need to deal with credentials directly at all.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.