Unable to install SSL certificate on my wordpress website hosted on GCP


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: geektribe.in

I ran this command:
wget https://dl.eff.org/certbot-auto && chmod a+x certbot-auto

./certbot-auto certonly --webroot -w /opt/bitnami/apps/wordpress/htdocs/ -d geektribe.in -d www.geektribe.in

It produced this output:

Certbot has problem setting up the virtual environment.
_We were not be able to guess the right solution from your pip _
output.
Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions.
You may also find some support resources at https://certbot.eff.org/support/ .

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:
Google Cloud Platform

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):


#2

Seems likely to be a PIP problem…
[not a lot of information to work with]

But in the meantime, have you updated the system?


closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.