Unable to get a certificate issued

My domain is: secwepemctsingames.tru.ca

I ran this command: sudo certbot --apache

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log

Plugins selected: Authenticator apache, Installer apache
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org

Which names would you like to activate HTTPS for?


1: secwepemctsingames.tru.ca
2: www.secwepemctsingames.tru.ca


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel):
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for secwepemctsingames.tru.ca
http-01 challenge for www.secwepemctsingames.tru.ca
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.secwepemctsingames.tru.ca (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: dns :: DNS problem: NXDOMAIN looking up A for www.secwepemctsingames.tru.ca

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.secwepemctsingames.tru.ca
    Type: connection
    Detail: dns :: DNS problem: NXDOMAIN looking up A for
    www.secwepemctsingames.tru.ca

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): Apache/2.4.6

The operating system my web server runs on is (include version): Apache/2.4.6 (CentOS) OpenSSL/1.0.2k-fips PHP/5.4.16

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot --apache

Hi @gaber79

your non-www version has an ip address ( https://check-your-website.server-daten.de/?q=secwepemctsingames.tru.ca ):

But your ww version

Host T IP-Address is auth. ∑ Queries ∑ Timeout
secwepemctsingames.tru.ca A 206.123.187.31 yes 1 0
AAAA yes
www.secwepemctsingames.tru.ca Name Error yes 1 0

doesn’t have an ip address.

So you can’t create a certificate with that domain name using http-01 validation.

Update your dns settings, add an A-record

www.secwepemctsingames.tru.ca -> same ip address

Perhaps you should create one certificate with both domain names (non-www and www).

Thank you for helping. I decided to delete the alias as I won’t need it. After removing the alias, I restarted servers and firewalls. I now get this error.

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org

Which names would you like to activate HTTPS for?


1: secwepemctsingames.tru.ca


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for secwepemctsingames.tru.ca
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. secwepemctsingames.tru.ca (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://secwepemctsingames.tru.ca/.well-known/acme-challenge/LvMIEUvgM1qwn9tXvCJyew9Dx5XRFQbj48Lhpcifj8Q: Timeout during connect (likely firewall problem)

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: secwepemctsingames.tru.ca
    Type: connection
    Detail: Fetching
    http://secwepemctsingames.tru.ca/.well-known/acme-challenge/LvMIEUvgM1qwn9tXvCJyew9Dx5XRFQbj48Lhpcifj8Q:
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

This was after I tried sudo certbot --apache again

There is a new check of your domain - https://check-your-website.server-daten.de/?q=secwepemctsingames.tru.ca

Your http doesn’t answer.

That’s required to use http-01 validation.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.