Unable to get a certificate in tsplus

Hi,

Can anyone give me some light on this little problem?

I have a new VM created in Azure where I have installed the TSPLUS application and from the application I try to generate a certificate but I get the error 805 and I do not know completely what it can be.

My domain is otazu.com and I have that domain registered in the IONOS provider. in otazu.com domain I registered the name of the server to point to the DNS record of the VM in Azure. In principle doing a dnslookup resolves me but inside the server when generating the certificate something does not like it.

I have tried disabling the windows Firewall but the same thing happens.

Is there any functionality of azure that by default blocks the communication?

Thanks!

1 Like

Your thread is more suitable for the Help section instead of the Ayuda (en Español) category as I don't see any Spanish words in your post. I'll move the thread also.

If you would have opened this thread in the Help section, you would have been provided with a questionnaire. Please fill out the questionnaire below to the best of your knowledge:


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Hi @Osiris

Thank you for your reply...You´re right...I wrote in english but I´m spanish..finally I did it in english waiting a spanish answer...

I saw the questionary but I don´t understand so many fields..

I didn´t run a command, I didn´t get an output, the web server is embebed in tsplus, etc etc etc.

These are the reasons...If you can help me I much appreciate it.

sorry

We have seen several problems with TSPlus recently. Asking their support may be better option. If they can explain what the 805 error means we could maybe help. But, without more details it is hard to give advice.

Please see this other thread with 805 error and link to TSPlus support

Also be sure to have the latest version of TSPlus. It relies on some other software that was recently updated

3 Likes

805 is their error code for domain validation failed. I just googled 805 tsplus: TSplus Remote Access - Documentation

They have logs you can look at.

Keep in mind that you need to allow TCP port 80 on the Azure networking setting in the azure portal, as well as allowing TCP port 80 at the windows firewall.

4 Likes

Thank you @MikeMcQ and @webprofusion.

The issue has been solved.

Adding the ACL in the NSG group the rule port 80 any any allow has worked for me. but I don´t understand having the rule port 80 my public IP destiny the IP of my server in Azure allow the request for the certificate didn´t work...I was with internet connection, etc...but the request didn´t work.

Thank you for your support!

Regards!!

2 Likes