Certbot not gererating certificate on Windows Azure VM

Hi,
My Azure VM (Windows Server 2019) with IIS having multiple IP addresses. I have multiple websites hosted on it. I opened ports 80 and 443 from Azure Portal for this VM and in Windows Firewall on VM itself. I tried after turning off the firewall as well. Still getting the below response.

My domain is:
admin.myprincessautorewards.com

I ran this command:
certbot certonly --webroot
After this, I enter the domain name and the webroot path of this website when prompted.

It produced this output:
Saving debug log to C:\Certbot\log\letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Please enter in your domain name(s) (comma and/or space separated) (Enter 'c'
to cancel): admin.myprincessautorewards.com
Requesting a certificate for admin.myprincessautorewards.com
Performing the following challenges:
http-01 challenge for admin.myprincessautorewards.com
Input the webroot for admin.myprincessautorewards.com: (Enter 'c' to cancel): E:\Web_Applications\PALCLP\admin.myprincessautorewards.com
Waiting for verification...
e[31mChallenge failed for domain admin.myprincessautorewards.come[0m
http-01 challenge for admin.myprincessautorewards.com
Cleaning up challenges
e[31mSome challenges have failed.e[0m
e[1m
IMPORTANT NOTES:
e[0m - The following errors were reported by the server:

Domain: admin.myprincessautorewards.com
Type: connection
Detail: Fetching
http://admin.myprincessautorewards.com/.well-known/acme-challenge/2BN8ujuj3Zzd0uaayLrZh2ME6toM5emIPNf3eO8Tmr4:
Timeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you're using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

My web server is (include version):
IIS 10.0.17763.1 On Windows Server 2019

The operating system my web server runs on is (include version):
Windows Server 2019 (Virtual machine) on Azure

My hosting provider, if applicable, is:
Azure VM

I can login to a root shell on my machine (yes or no, or I don't know):
i don;t know

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
no, it is developed in ASP.Net Core C#, right now I just put an index.html page.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
certbot 1.13.0

Hi @manish.sharma

I can't open that url in my browser. Timeout.

So you have something that blocks. Find and remove it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.