Error upon requesting certificate on Azure Windows VM

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: devinvtestwin1.southeastasia.cloudapp.azure.com

I ran this command: certbot certonly --standalone --agree-tos --email personalmail@gmail.com -d devinvtestwin1.southeastasia.cloudapp.azure.com

It produced this output: Hint: The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet

My web server is (include version): N/A

The operating system my web server runs on is (include version): Windows Server 2019

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): via RDP

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 2.2.0

Currently the firewall that is setup on my azure machine is allowing port 80 on my public IP. Is that the culprit on this? And should I open all inbound connections?

Only open port 80 should be necessary. There's probably something more blocking access to port 80. Perhaps in the Azure settings/panel/firewall/whatever or Windows itself?

3 Likes

On the VM itself, I already added an inbound rule to allow port 80. On Azure I tried to open port 80 to all but I still encounter the same error. I've tried installing nginx to check if I can access the domain on my personal workstation and it is successful. Any other logs that can help me troubleshoot this?

Maybe you can show the entire error message, maybe the reference to port 80 et cetera is just a generic part of the error message.

3 Likes

curl: (6) Could not resolve host: devtestwin1.southeastasia.cloudapp.azure.com

Did you spell the name correctly?

2 Likes

Oh sorry. I had to change the domain to mask our org :sweat_smile:

I changed it to devinvtestwin1.southeastasia.cloudapp.azure.com

If nginx is accessible via HTTP, then you should be able to obtain a cert for that name.

Try using the staging/test environment until everything works as expected.

3 Likes