Unable to complete challenge on Azure Function App

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: givingdaisies.org

I ran this command: Installed and configured the Site Extension for Azure Let’s Encrypt

It produced this output:

Unable to complete challenge with Lets Encrypt servers error was: {“type”:“http-01”,“url”:“https://acme-staging-v02.api.letsencrypt.org/acme/chall-v3/33422647/NNxjzg",“status”:“Invalid”,“validated”:null,“error”:{“Type”:“urn:ietf:params:acme:error:unauthorized”,“Detail”:"Invalid response from http://alerttologanalytics-floyd63.givingdaisies.org/.well-known/acme-challenge/5HbChrToZppMR5ba5o44VwmAHajgEjE1wcmjivlrgZ0 [40.71.11.139]: 404”,“Identifier”:null,“Subproblems”:null,“Status”:403},“errors”:null,“token”:“5HbChrToZppMR5ba5o44VwmAHajgEjE1wcmjivlrgZ0”,“keyAuthorization”:null}

My web server is (include version): Azure Function App

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Azure

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

I created the Function App and deployed to Azure.

Hi @chrisc1122

there is no ip address - https://check-your-website.server-daten.de/?q=givingdaisies.org

Host T IP-Address is auth. ∑ Queries ∑ Timeout
givingdaisies.org A yes 1 0
AAAA yes
www.givingdaisies.org Name Error yes 1 0

Your complete test domain is required.

Not sure what you mean. There is no www, it is a function app ?

If you want to use http validation, a DNS entry yourdomain -> ipaddress is required.

But there is no ip address.

So what’s the domain name you have used to create your error message?

Check that domain name and check the /.well-known/acme-challenge part.

http://alerttologanalytics-floyd63.givingdaisies.org

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.