Lets Encrypt returned an empty error for domain


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: apidocs.bloombox.cloud

I ran this command: LetsEncrypt.register API

It produced this output:

"error": {
  "isOperational": true,
  "cause": {}
}

I tried to register a certificate for this domain and I got the above error from letsEncrypt. After trying multiple times letsEncrypt starts throwing this error

"error":{"cause":{"code":"E_STATUS_CODE","type":"urn:acme:error:malformed","description":{"type":"urn:acme:error:malformed","detail":"Unable to update challenge :: The challenge is not pending.","status":400},"detail":"Unable to update challenge :: The challenge is not pending."},"isOperational":true,"code":"E_STATUS_CODE","type":"urn:acme:error:malformed","description":{"$ref":"$[\"error\"][\"cause\"][\"description\"]"},"detail":"Unable to update challenge :: The challenge is not pending."}

I checked the letsEncrypt supported tlds too and .cloud is allowed there too.


#2

What ACME client/software are you using? At face value this looks like an error caused by the ACME client.


#3

@cpu I am http-01 challangeType.


#4

Hi @pjoshi - that’s the ACME challenge type you are using. What ACME client software are you running to use that challenge type?


#5

@cpu We are using letsEncrypt node module which is older version of greenLock. Hope that is what you are looking for.


#6

You should open a bug report with the developers. It sounds like the client (or your code using the client) is POSTing challenges of an authorization that is likely invalid from a previous challenge attempt that failed, or already valid and being returned based on authorization reuse.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.