Trying to renew SSL Certificate: Authorization for the domain failed


#1

I am attempting to renew SSL Certificates on my websites. It has been working automatically up until now, but now I am getting this error when I attempt to renew my certificate:

Error: Could not issue a Let’s Encrypt SSL/TLS certificate for alabama-music.com. Authorization for the domain failed.

Invalid response from https://acme-v01.api.letsencrypt.org/acme/authz/Hxc8p5V0BceTCXrb5mxkEKgKwp7vPTXu2K_adsFfnYk.
Details:
Type: urn:acme:error:connection
Status: 400
Detail: Fetching https://alabama-music.com.well-known/acme-challenge/V0sfH6wWrB-wFpMhWBwgA5Qt1qKVzoDB7JZaW3wC1sI: Error getting validation data

At first I thought it could be that I was reaching my rate limit for the week, but I have tried again unsuccessfully first thing Monday morning, so I am not sure if this is the case anymore, unless the server is automatically attempting and failing to renew the certificates over 20 times within a few hours.

Does anyone have any insight into this? I am a web designer and do not have much knowledge about this stuff and my systems administrator is difficult to get a hold of and unhelpful when I can.

My two domains are:
https://alabama-music.com/ (I deleted this SSL Certificate in an effort to re-install a fresh one. DId not work)
https://menzel-music.com/ (Still has an expired SSL Certificate)

I ran this command: I cannot run commands (via terminal)

It produced this output:

My web server is (include version): Linux

The operating system my web server runs on is (include version): I am not sure

My hosting provider, if applicable, is: Rackspace

I can login to a root shell on my machine (yes or no, or I don’t know): No

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Plesk Onyx


#2

Look closely, the domain name is appended with “.well-known/”, this cannot work. You most likely have a misconfigured redirect from http to https (slash missing in redirect target).


#3

Thanks so much for that info, you are correct, I indeed had it set up like this.

I am now getting this error:

Error: Could not issue a Let’s Encrypt SSL/TLS certificate for alabama-music.com.

The “Failed Validation” rate limit has been exceeded for alabama-music.com. Let’s Encrypt allows no more than 5 authorization validation request failures per account, per hostname, per hour.
See the related Knowledge Base article for details.
Details
Invalid response from https://acme-v01.api.letsencrypt.org/acme/new-authz.
Details:
Type: urn:acme:error:rateLimited
Status: 429
Detail: Error creating new authz :: too many failed authorizations recently: see https://letsencrypt.org/docs/rate-limits/

According to the error, the failure rate limit resets in an hour, so I will test this again in about an hour and follow up here again.

Thank you for the quick response, greatly appreciated.


#4

This has fixed the issue. Thanks :slight_smile:


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.