Trying to generate a certificate but I run on some limits


#1

I made a lot of requests try to make a usable configuration, now certbot only prints limits reached.

Obtaining a new certificate
An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many failed authorizations    recently: see https://letsencrypt.org/docs/rate-limits/
Please see the logfiles in /var/log/letsencrypt for more details.

What should I do now :slight_smile: ?

I want to manually create the certificate, I added routes in nginx for the .wellknow, but when I finally got it right Let’s Encrypt banned me :D.

My Nginx is listening on port 81 for the moment, cause I am migrating my main server from Apache to Nginx, and I need https to work, probably 8443 will be needed in this case as well.

This is the command I use:

certbot certonly --webroot -w /home/myuser/beta/ -d beta.mydomain.mk:81

And this is the Nginx route:

   location /.well-known {
       alias /home/myuser/beta/.well-known;
   }

Can someone guide me how to remove the ban and configure my Nginx server for 8443, please?


#2

Ok, I found this https://letsencrypt.org/docs/staging-environment/, but I am still not able to convince the certbot client to use port 81.


#3

Ok, I swapped the running Apache server with Nginx to run at 80, and the certificates were generated.

I think I solved my issue :).


#4

Hi @gnud

there is a documentation:

There is a Failed Validation limit of 5 failures per account, per hostname, per hour. This limit is higher on our staging environment, so you can use that environment to debug connectivity problems.

5 failures per account, hostname and hour. But to test, the stage environment is the best idea.


#5

Yes, thanks for the link, that’s how I solved it.
At the moment I generated a stagging certificate.

I will generate live one when I launch the 443 officially :).

So, how do I mark this as solved?


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.