Trouble Renewing Certificate


#1

Hi All,
I’m not the most technically savvy user, but have letsencrypt SSL certificates for my website dailydigitalnews.com and everything had worked fine until recently and I can now no longer get the certs to work properly.

“This connection is not private warning.
This website’s security certificate expired 32 days ago.”
I suspect the site actually crashed and was down around the time the last certificate needed to renew.
The cert is a Let’s Encrypt Authority X3

I am using the plesk plugin which seems to provide the opportunity to renew the certificate which complete’s but then nothing really happens. Not a lot comes back from plesk descriptively other than:
“Information: The Let’s Encrypt SSL/TLS certificate has been installed on dailydigitalnews.com.”

I can also see where i can view / upload certificates in plesk, but can’t find the same on the letencrypt side.

I have access to the SSH shell, but am somewhat out of my depth using terminal and command lines, not that I’ve even found much to copy and paste and try. Any advice or suggestions on where to from here would be greatly appreciated.

My domain is: dailydigitalnews.com
CentOS Linux 7.5.1804 (Core)‬,
Plesk [12.5.30 Update #79]


#2

I’m going to speculate that this some kind of malfunction within the Plesk plugin. It seems to be issuing certificates (as recently as 3 days ago) but doesn’t seem to actually apply them to your webserver.

Do you have a support contract with Plesk or anything like that?

Have you tried the workflow using the Let’s Encrypt Plesk extension shown in these screenshots?

Just one warning - be cautious trying to renew the certificate continually when it doesn’t seem to be applying. You only have 3 more attempts available this week before you hit rate limits for that certificate.


#3

You were correct - the problem was that plesk had failed to update, and the let’s encrypt extension was at fault. Resolved now :slight_smile: Thanks.


closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.