Trouble issues a certificate via cpanel


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: http://www.hbsring.co.uk

I ran this command: Attempted to issue via cpanel

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version): Litespeed

My hosting provider, if applicable, is: Smart Hosting (https://www.bestwebhosting.co.uk/)

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): cpanel

I have created lots of LetsEncrypt certificates via cpanel but this one is not working as per the attached capture

I am not the DNS holder, that is managed by another party but A records have been amended to divert web traffic to me for displaying the website, it is on that hosting space I am attempting to issue the cert.

Could this be that the DNS changes all need time to settle or do I need to add a TXT record at the DNS for authenticating the cert issuing?

Any help would be great, thanks


#2

Hi,

The 3 domains/subdomains you are trying to issue certificates for, all have different IP addresses - only www. actually points to your cPanel server:

www.hbsring.co.uk.      86245   IN      A       77.72.0.78
hbsring.co.uk.              86399   IN      A       62.233.121.75
mail.hbsring.co.uk.     86399   IN      A       84.22.161.135

It’s best to ensure that your base domain and www subdomain point to the same place.

Whether you update mail. to the same place depends on how you’re setup, but you can always simply uncheck that domain in the Let’s Encrypt interface when going to issue your certificate.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.