Trouble getting https to work

My domain is:

I ran this command: sudo certbot certificates

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Found the following certs:
Certificate Name:
Expiry Date: 2020-11-05 08:06:54+00:00 (VALID: 89 days)
Certificate Path: /etc/letsencrypt/live/
Private Key Path: /etc/letsencrypt/live/

My web server is (include version): Apache/2.4.38 (Raspbian)

The operating system my web server runs on is (include version): Raspbian Debian 10

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

When trying to connect to my site,, it will autoconnect to the http version and work fine. But after changing it to https, it does not work anymore.

I already found out that the certificate of the domain is not assigned by certbot, but instead, by “root.home” (see image for reference).

Is there some way to somehow force the domain to use the certificate provided by certbot?

I am pretty new to all of this stuff, so please bear with me.

1 Like

It sounds like your modem/router is eating the connections to port 443, instead of port forwarding them to your Raspberry Pi.

So, two things to check:

  • That you have setup port forwarding for port 443, not just for port 80.
  • If applicable, change your modem/router’s admin port from port 443 to something else. Freeing it up for your own personal use.

After you made that change, it started working for me.

1 Like

Thank you so so much! I just realised it worked on my phone! You’re an absolute legend man! :smiley:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.