Total web development Noob getting an error on initial SSL installation via ZeroSSL


#1

My domain is: topfoodiefaves.com

I ran this command: Invalid response from http://topfoodiefaves.com/.well-known/acme-challenge/Bc8OgnjiNVjKLALMTxPzzGiMqnTHTB5TDtaWZJpjCRg: “<!DOCTYPE html>\n<html lang=“en” prefix=“og: http://ogp.me/ns#”>\n<head >\n<meta charset=“UTF-8” />\n<meta name=“viewport” content=”"

It produced this output:

My web server is (include version): I don’t know

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: GoDaddy

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):CPanel


#2

Hi,

Could you please check if the folder .well-known is created under your domain’s document root? and acme-challenge is created under.well-known ?

Also, please note It’s .well-known, not well-known.

Thank you


#3

Hi Steven,

Just wanted to start off by saying thank you for helping me.

I moved .well-known under public.html because it wasn’t working properly when I had it as a root folder.

When I tried to verify/test the key with the link it went to my wordpress blog with a 404 error within the theme so I tried to skip that test and validate but it’s still not working


#4

Hi,

Where do you put all your WordPress files? You should put that folder under the same folder (presumably public-html)…

After checking all the steps above, please check if .well-known and (inside .well-known) acme-challenge has 755 as permission.

If all above is done, please try to create a file under .well-known/acme-challenge/ (a dummy file without extension) and try to view it in your browser.

P.S. Here’s an official guide from GoDaddy: https://www.godaddy.com/help/install-a-lets-encrypt-certificate-on-your-cpanel-hosting-account-28023

Thank you


#5

Hi,

The wordpress files are in the public_html folder.

well-known and acme-challenge has 0755 as permissions

I think I did this step right. I used TextEdit and created a document with random text in it and saved it without the extension .txt at the end and placed it in the acme-challenge folder and ran http://topfoodiefaves.com/.well-known/acme-challenge/untitled but got the error. See screenshot


#6

Hi,

Can you please take a look at the Error Log section on your GoDaddy cPanel?
There might have some error…

Beside that, maybe there’s a cache in place? (But i can’t find any evidence on this case since my site is working properly with wp-rocket in place)

Thank you


#7

I have a cache plugin running. Should I try deactivating that?

This is what I found in the Error Log section:
[Thu Oct 11 21:16:07.628051 2018] [autoindex:error] [pid 527690:tid 140061408507648] [client 71.204.116.109:8479] AH01276: Cannot serve directory /home/ihnvfoss0wog/public_html/.well-known/: No matching DirectoryIndex (index.html.var,index.htm,index.html,index.xhtml,index.wml,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.js,index.jp,index.php4,index.php3,index.php,index.phtml,index.shtml,default.htm,default.html,home.htm,index.php5,Default.html,Default.htm,home.html,welcome.html) found, and server-generated directory index forbidden by Options directive
[Thu Oct 11 20:53:54.161279 2018] [autoindex:error] [pid 527746:tid 140061131601664] [client 71.204.116.109:5945] AH01276: Cannot serve directory /home/ihnvfoss0wog/public_html/.well-known/acme-challenge/: No matching DirectoryIndex (index.html.var,index.htm,index.html,index.xhtml,index.wml,index.perl,index.pl,index.plx,index.ppl,index.cgi,index.jsp,index.js,index.jp,index.php4,index.php3,index.php,index.phtml,index.shtml,default.htm,default.html,home.htm,index.php5,Default.html,Default.htm,home.html,welcome.html) found, and server-generated directory index forbidden by Options directive


#8

Hi,

I’m reallly sorry but i can’t seems to find a correct answer to this matter…

Maybe you’ll need to contact GoDaddy hosting for this?

Thank you


#9

Hi,

Could you please try to clear the cache on W3 total cache?

and possibly temperorily disable the cache for 404 pages? (Your 404 page is cached by W3)

Thank you


#10

Hi,

I just cleared the cache on W3. I couldn’t see an option to temporarily disable the cache for 404 pages but I went ahead and just disabled the cache in general for now. I hit the same error running http://topfoodiefaves.com/.well-known/acme-challenge/untitled

Does it possibly have anything to do with my root name? It’s not my domain name, it’s like a username or something for reason.


#11

Hey everyone.

I was wondering if anyone has encountered a similar setup issue with a Wordpress site on GoDaddy before? Would love to be able to get this working. Thanks in advance!


#12

Hi,

Sorry for the non-reply…

I’ve encountered one people with the same issue (around your time of encounter) and have the same situation…

Not sure what’s going on without checking on the server itself…

Maybe GoDaddy support could (possibly) resolve this?

One guess…

Could you please try to put a dummy index.html under the .well-known/acme-challenge/?

This might solve the non-index issue.

Thank you