Too many certificates already issued for exact set of domains

I tried to make an SSL and I got an error where I can't make anymore Certificates. So I went to bed woke up the next day and now its been 24+ hours since I tried. But I still cant make it, I check the link and its a new week so I honestly don't know, If there's any way I can make a certificate I would love to know.

Best Regards,
Luke S.

My domain is: and

I ran this command: certbot certonly -d

It produced this output:
Obtaining a new certificate
An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many certificates already issued for exact set of domains: see
Please see the logfiles in /var/log/letsencrypt for more details.

My web server is (include version): 1.14.0

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: Google Cloud Compute

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.31.0

1 Like

Please use one of the 5 certificates issued in the last week.


How could I do that?

1 Like

They should be available in /etc/letsencrypt/live/

You've issued 5 certificates recently: Use them. Don't hog the Let's Encrypt servers any longer. For testing, you should have used the staging environment.


The File Doesn't Exist And I Also Deleted My VPS Since I Thought It Would Fix It and remade it.

1 Like

That's almost always not a very sensible thing to do.

It didn't. It got you in trouble.

If you want this exact same set of hostnames in your certificate, you've got to wait a week since the 10th, so another day or so.

1 Like

Man that really sucks for me and I cant do anything to fix it, since I really wanted to make a certificate. And yha I know its not very smart to delete my VPS But i was getting errors and I'm new to the whole Linux thing, Sorry.

1 Like

Do you have a backup? If not, another thing to learn :wink:

If you look at the total amount of certificates for your domain:

it stands out you didn't include the www subdomain in any of them.

If you read the rate limit documentation (see the error message) very well, you can make out the following:

If you changed the set of hostnames by adding [ ], you would be able to request additional certificates.

So if you combine the panel subdomain hostname with the www subdomain hostname and the base domain name, you'll have a single certificate with three hostnames.


So could i do or would it need to be like this Also i do have a snapshot so i could probably get the files from it. But it would delete all my current work just to check the file.

1 Like


Not necessarily. It could be if you'd like.

You can't "extract" files from the snapshot? It's an "all or nothing" kinda thing? If so, I'd recommend another backup strategy which enables you to extract single files.

1 Like

If your snapshot system worked anything like any other...
You could save the current state and then restore a previous one.
Copy out whatever you needed.
Then restore the most recently saved one (and your back to where you where).


So what files would I be looking for?

1 Like
1 Like

Those are just symlinks though, you'll also need the files they're pointing to.

1 Like

BlackWolf has already created a new topic regarding migration of certificates to a new VPS:

1 Like