To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address

Hello,
My domain name is guithe.com purchased from Amazon. And i have hosted it on amazon web server using ec2 instance amazon linux AMI operating system.
I tried to create certificate for guithe.com and www.guite.com and as well. But i am getting error

[ec2-user@ip-000000000html]$ sudo ./certbot-auto --authenticator webroot --installer apache -w /var/www/html

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter ‘c’ to cancel): guithe.com www.guithe.com
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for guithe.com
http-01 challenge for www.guithe.com
Using the webroot path /var/www/html for all unmatched domains.
Waiting for verification…
Challenge failed for domain guithe.com
Challenge failed for domain www.guithe.com
http-01 challenge for guithe.com
http-01 challenge for www.guithe.com
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

Thank

1 Like

Hi @blasy

if you use webroot and if that doesn’t work, your webroot is wrong or you have additional definitions / an application that blocks.

What says

apachectl -S

There are checks of your domain - https://check-your-website.server-daten.de/?q=guithe.com

Most is ok, but /.well-known/acme-challenge/random-filename answers with a

Visible Content: 404 Go Home

that’s not the standard Apache answer.

2 Likes

Thanks, could you tell me how to solve this please?

[ec2-user@ip-00000000 html]$ apachectl -S
VirtualHost configuration:
*:443 ip-00000000.eu-west-3.compute.internal (/etc/httpd/conf.d/ssl.conf:56)
ServerRoot: “/etc/httpd”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/etc/httpd/logs/error_log”
Mutex authdigest-opaque: using_defaults
Mutex watchdog-callback: using_defaults
Mutex proxy-balancer-shm: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
Mutex authdigest-client: using_defaults
Mutex lua-ivm-shm: using_defaults
Mutex ssl-stapling: using_defaults
Mutex proxy: using_defaults
Mutex authn-socache: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/httpd/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex cache-socache: using_defaults
PidFile: “/var/run/httpd/httpd.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“apache” id=48 not_used
Group: name=“apache” id=48 not_used

Help me please mister

You have no configuration that covers the names you need:
guithe.com
www.guithe.com

You may need to read up on how to configure a web server.

1 Like

Hello, thank you for your answer. I configured my server well because I have two amazon linux AMI instances for the first everything went well and it is this one that complicates me, I delete the instance and recreate 2 times with the same configuration as the first I come across the same error

There

you see your problem.

No port 80 vHost with your two domain names.

Create one.

2 Likes

Hello,
Thank you for your reply.
Could you tell me how to create it. please.
Thank you

1 Like

Thank you all for your help.
The problem is solved.
I delete the instance and create another, I bought a new domain name and made the same configuration and everything is good with the new domain purchased. Thank you

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.