To fix these errors, please make sure that your domain name was entered correctly and the DNS A/AAAA record(s) for that domain contain(s) the right IP address

Hello,
My domain name is forty8byforty.com purchased from godaddy. And i have hosted it on amazon web server using ec2 instance ubuntu 18.04 operating system.
I tried to create certificate with forty8byforty.com and www.forty8byforty.com as well. But i am getting error

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.forty8byforty.com
    Type: unauthorized
    Detail: Invalid response from
    http://www.forty8byforty.com/.well-known/acme-challenge/FfITyOZytvI9ZBG6c3r_CmMacmzz2OeTDBrxY2WAldA
    [3.19.143.139]: "\n<html lang=“en”>\n \n

    \n <meta name=\"viewport\" content=\"width=device-w"

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.
    I also have a dev server too, which is dev.forty8byforty.com a while ago I installed ssl certificate on my subdomain which installed easily. Can anyone please help me how can i overcome this issue? I am using apache2 on my server
    Thanks in advance

1 Like

Hi @kashifmit

there are checks of your domain, ~~ two hours old - https://check-your-website.server-daten.de/?q=forty8byforty.com

First, your non-www doesn’t have an ip address. That’s required if you want to use http validation.

Second, the main things are ok: Port 80 + /.well-known/acme-challenge/random-filename answers with the expected result http status 404 - Not found. No blocking firewall.

There is an Apache. What says

apachectl -S
1 Like

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

I ran this command:

It produced this output:

My web server is (include version):

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi,
Thank you for your reply. I just assigned to my non-www i.e. forty8byforty.com same ip address which is assigned to my www.forty8byforty.com in my amazon console using route53 service. but it is still showing blank in check your website the link you sent me in the above post. Can you please let me know is it OK or would you suggest any other option?

Thanks in advance :slight_smile:

The check is two days old. Did you recheck your domain?

I am checking it continuously here https://check-your-website.server-daten.de/?q=forty8byforty.com but it is showing as it was previously.
I tried by creating cerbot certificate its also giving the same previous error.

IMPORTANT NOTES:
** - The following errors were reported by the server:**

** Domain: www.forty8byforty.com**
** Type: unauthorized**
** Detail: Invalid response from**
** http://www.forty8byforty.com/.well-known/acme-challenge/aIwzKv_O1_g1jGdCPdbFOeo-Ht5MzMJW8PGuEapUtc0**
** [3.19.143.139]: "\n<html lang=“en”>\n \n**
** <meta charset=“utf-8”>\n <meta name=“viewport”**
** content=“width=device-w”**

** To fix these errors, please make sure that your domain name was**
** entered correctly and the DNS A/AAAA record(s) for that domain**
** contain(s) the right IP address.**

Please check the screen shot of my domain map setting on route 53

Thanks in advance :slight_smile:

Click “Check”. You see the result created 05.01.2020 13:38:37. So it’s not your current configuration. There is no automated update, you see saved results.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.