Requesting a certificate for (sitename)
Performing the following challenges:
http-01 challenge for (sitename)
Enabled Apache rewrite module
Waiting for verification...
Challenge failed for domain (sitename)
http-01 challenge for (sitename)

Certbot failed to authenticate some domains (authenticator: apache). The Certificate Authority reported these problems:
Domain: (sitename)
Type: unauthorized
Detail: Invalid response from http://(sitename)/.well-known/acme-challenge/(key): 404

Hint: The Certificate Authority failed to verify the temporary Apache configuration changes made by Certbot. Ensure that the listed domains point to this Apache server and that it is accessible from the internet.

Cleaning up challenges
Some challenges have failed.
Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

Is that really your IP? Because it looks like a URL Rewrite or URL Forwarding service and not a normal DNS A record. I say that because it is for AWS Global Accelerator and many hosting providers use that for such a purpose (like GoDaddy)


Nobody can really help you without some basic information like your domain.

For http validation to work your server running certbot needs to respond to the HTTP challenge, and if you are using something exotic like an AWS load balancer (we're guessing based on the IP address shown) then all the responding hosts need to be able to respond to the challenge with the same reply.


Hi @Vitaly123, and welcome to the LE community forum :slight_smile:

If that is your IP address, I would start by reviewing the output of:
sudo apachectl -t -D DUMP_VHOSTS

And in all cases, I would fill out the questionaire that you should have been presented with when choosing "HELP":
[feel free to translate it into your preferred language]

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


ye, i use godaddy

its not my ip

You need to change your DNS config so it has an A record for your public IP. You will need to disable the GoDaddy URL Redirect / Forwarding service to do this. That will not work to setup HTTPS.


ye, i find this ip in dns setting, but i dont delete this ip, (Can't remove)
sorry, my eng so bad :c

i dont now where create this ip, how delete

1 Like

Yes, you must first disable or stop the URL Forwarding and then you can setup your DNS A records. I'm not sure how you do that but maybe this


ye, i give good result with sertificate, but my domen dont work, not loading in browse

1 Like

Maybe browser cached old bad info. Refresh browser

Your cert looks good. Use a site like this to test it


ye, (It's all good. We have not detected any issues.)
clean cache, but site dont work, may be you need more info, and help me

I see a default WordPress admin / install page

Our job is usually done once you get a valid cert used by your server.

Beyond that is usually just server and application design.


why i dont use this site in my internet connection. another connection dont have prob, but my internet ip, dont work

Sorry. I am signing off for night.

But, can you explain more in your own language? We can use google translate


да, спасибо большое за помощь, вы действительно очень помогли, спасибо!
через мой интернет (интернет провайдер ethernet) не получается зайти на сайт, но через мобильный интернет получается

1 Like

I'm able to connect via HTTP - It redirects to HTTPS.
I'm also able to connect via HTTPS now.
I see a new site about philosophy.


да, мы пока не настраивали его, а почему я не могу зайти на него через свой интернет?

There could be different reasons for that.
Are there any geo-location based IP blocking?