Timeout when attempting to make certs with certbot

Domain: www.t00thpick1.net
Configuration: Nginx on Centos 7
Command: certbot-auto --nginx --test-cert -d www.t00thpick1.net
Result:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Obtaining a new certificate
Performing the following challenges:
tls-sni-01 challenge for www.t00thpick1.net
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.t00thpick1.net (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Timeout

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: www.t00thpick1.net
    Type: connection
    Detail: Timeout

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

Hi @t00thpick1,

It looks to me like you have a firewall (whether a host firewall like ufw or a network firewall like a VPS provider’s network port policy settings) blocking inbound connections to port 443. This is preventing certbot-auto --nginx from completing the challenge to prove your ownership of this domain name. Do you think you could find where this firewall policy is and disable it?

I realize now I had disabled my 443 forwarding on my firewall… thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.